On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Background
    I just used the updatemodx snippet to update modx from 2.6.5 to 2.7.0 on December 10th. I am not sure if that caused the issue since the issue did not surface until dec 12. Possibly I did not attempt to edit any resources with the problem templates.

    Modx 2.7.0
    PHP Version 5.5.38
    database 10.0.36-MariaDB

    Troubleshooting Attempts

    • cleared core/cache
    • rerun setup
    • optimized db table

    Issue Description

    Issues with using update

    • When attempting to update resources I get a blank page.
    • I am able to view/edit with quick update.
    • If I create a new resource using one of the templates, I can save but can not update the page after closing.
    • If I quick update and change to a working template, I can then open using update.


    Issues Creating new Resources

    • When I create a resource using a problem template, I get a blank page when I click on the template variables tab.


    Are Template Variables the problem?


    • I am considering testing by unchecking the TVs for the template, and then trying to open the resources with the problem templates
    • Redesigning new templates with new TVs and switching to new template via either quick update or batcher

    I have backed up database and all files on the server.


    Open to all suggestions and ideas.

    Thanks
    Roy

    This question has been answered by rdegler. See the first response.

    • discuss.answer
      With one of the templates, I have identified the issue is a single Template Variable.

      The TV is a resource list.

      Working on the other Templates to determine if the issue is other TVs.

      I wonder what possibly caused the issue with the TV, was it the upgrade, DB issue, or a problem with modx.

      Thanks,
      Roy
      • It could be a mod_security issue. That's the most common cause when specific things can't be saved. The first thing to try, though, is using private or incognito mode in your browser, in case it's a leftover cache file or cookie from the earlier MODX version.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
        • I was able to fix the issue. I switched the TV to content type text. Test opening the resources for editing, worked fine. Then I switched back to content type resource and all worked as expected.

          Not sure why the issue arose. It might have had something to do with the upgrading modx from 2.6.5 to 2.7.0.

          Roy