We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 54737
    • 3 Posts
    I'm trying to upgrade my site which is running modx 2.3.3 (initially trying to just get it to 2.4.0). I tried to do it by manually over FTP but once I have completed the setup process it still shows at 2.3.3.

    I have now installed the Upgrade Modx extra but the button doesn't seem to be loading and I'm getting some errors logged in the console:

    'Failed to load resource: the server responded with a status of 404 () - progressbutton.js:1'
    'Uncaught ReferenceError: ProgressButton is not defined at ugm-bottom.js:43'

    Has anyone else had either of these problems before? & if so how did you fix them?
      • 36582
      • 463 Posts
      If you haven't already, log out, manually clear or rename the core/cache folder, clear your browser cache or try a different browser. Check what version shows, then try again.
        Web site design in Nottingham UK by Chris Fickling http://www.chrisficklingdesign.co.uk
        • 3749
        • 24,544 Posts
        +1 for chrisandy's suggestions.

        Also, did you run Setup after doing the FTP transfer?
        What version of UpgradeMODX are you using?
        What's your PHP version?
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 54737
          • 3 Posts
          Thanks for those suggestions - I have already tried logging out, clearing cache, different browsers but none of this has worked. The setup screen actually shows the current version as though I'm just installing the same version I'm already using. I'm wondering if it might be a permissions thing?

          @BobRay I'm using UpgradeModx 2.0.3. Currently running PHP 7.0, though I have also tried it on 5.6 and had the same issue.
            • 36582
            • 463 Posts
            One thing I had a few times when upgrade failed: The set up folder doesn't get removed so might be an idea to manually remove that and then run UpgradeModx again. Also, had problems with permissions of the core/config/config.inc.php file which I think has to be writable during upgrade. On occasion I've also had to set the date / timezone in setup/index.php to something like...

            @ ini_set('date.timezone', 'Europe/London');
              Web site design in Nottingham UK by Chris Fickling http://www.chrisficklingdesign.co.uk
              • 54737
              • 3 Posts
              Thanks again for the suggestion! I've just had a go at upgrading after changing the permissions of core/config/config.inc.php to 777 and setting the date/timezone and had the same result - after going through the setup process I still end up on 2.3.3. Are there any other files I might need to change the permissions on? Could it be to do with the way I'm uploading the files?
                • 3749
                • 24,544 Posts
                Try 644 for the config.inc.php file and 755 for the directories. Those are the most common settings for servers these days.

                If you uploaded the files individually with FTP, that often causes missing or corrupted files.

                Try the steps here: https://bobsguides.com/modx-upgrade-faq.html.

                Once you hit 2.4.0, I'd suggest un-installing and removing UpgradeMODX, then re-download and re-install it. It should work fine in 2.4.0 assuming that there's no problem with file and directory permissions.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting