Subscribe: RSS
  • mandledesign Reply #1, 3 months ago
    Hello,
    I'm trying to hide this forum posts from the public.
    I've changed Allow Guests to NO, which by the description of this setting I believe should make posts visible to only logged in members. I'm still able to view the forum without logging in. Logged out of both the forum and the MODX backend.

    MODX 2.5.7
    Discuss 1.2

    Also receiving these Errors
    [2018-10-17 11:30:50] (ERROR @ /public_html/core/xpdo/om/xpdoobject.class.php : 1452) Error 42S02 executing statement:
    INSERT INTO `modx_discuss_thread_participants` (`thread`, `user`) VALUES (24, 1)
    Array
    (
        [0] => 42S02
        [1] => 1146
        [2] => Table 'database.modx_discuss_thread_participants' doesn't exist
    )

    Sure enough this table does not exist

    I think this is unrelated to my issue but is another issue in itself. [ed. note: mandledesign last edited this post 3 months ago.]
    • I think you will need to hide it on the back end, you can check in the Manager > Discuss and then find the thread and change its permissions to only mods or admins.

      Seems to me this should work but I don't know if I tested it or not.
      • mandledesign Reply #3, 3 months ago
        It seems I may have to resolve this by blocking the entire forum with a login. I can't find a solution that would work otherwise.
        • That might be a good method. htaccess I assume?

          There is an extra called Personalize that will check for logged in user and give content based on that (hide content if not logged in).

          But it may be tough to do that for a forum page.

          Did you check on the back end? As I said you should be able to protect threads by changing permissions within Discuss manager
          • Did you get this resolved?

            In your manager under extras you will have discuss as a page of your manager. not where to add extras.

            In there you can see all your threads and so on. If you right click on a thread you can manage permissions.

            Also look at the options above in that dialog for other controls.