New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • Hi,

    Since the instalment of ModX 2.6.5 there have been problem getting Gallery 1.7.1. to work. This is what I already tried:

    - remove and re-install gallery 1.7.1 (also complete removal of the addon on the server) (multiple times)
    - tried if gallery 1.6.1 would work, it was not
    - re-instal the ModX 2.6.5 setup (multiple times)
    - checked if php mbstring is enabled

    Only thing I can imagine is that for a few weeks back the HTTPS-protocol wat set as default, but for as fat as I can see I set all the paths in ModX to HTTPS(?) Are there paths in Gallery that I should edit considering the HTTPS protocol?

    Ivo
    • This may be of some help:

      https://www.markhamstra.com/modx/2012/07/3-tips-for-serving-a-modx-site-over-ssl/

      Also, there's some tweaking that needs to happen in .htaccess for SSL. The info here may be of use:
      http://modx-gu.ru/configs/htaccess
        Frogabog- MODX Websites in Portland Oregon
        "Do yourself a favor and get a copy of "MODX - The Official Guide" by Bob Ray. Read it.
        Having server issues? These guys have MODX Hosting perfected - SkyToaster
      • Gallery 1.7.1 works fine on https so what issues are you having with it ?, any errors in the error log ?
        • Gallery Browser does not display pictures byt They are in place, and are visible on the website. The problem started when I migrate website to https.
          Gallery Browser show me: "No files match the specified filter."
          Any help?
          (Sorry for my bad english

          error log:
          [2018-10-25 12:41:55] (ERROR @ /home/myname/public_html/core/xpdo/om/xpdoobject.class.php : 240) Error 42000 executing statement: 
          Array
          (
              [0] => 42000
              [1] => 1055
              [2] => Expression #13 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'myname_Modx.AlbumItems.rank' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by
          )