Have you checked your server's error log? Not the MODX error log, but the server error log. You'll probably find an indication there.
PHP 7.x is much more likely that earlier versions to throw a 500 error when it hits a PHP error that earlier versions would pass.
One common culprit involves not having php-mbstring installed.
https://stackoverflow.com/questions/21699774/internal-server-error-http-error-500-after-installing-phpmyadmin-on-a-certain.
Turning on display errors might give you a clue:
https://stackoverflow.com/questions/5680831/php-does-not-display-error-messages/5680885#5680885