New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • I've recently upgraded a site to 2.6.5, PHP7, moved core above root and renamed directories. Pthumb / Resizer isn't outputting anything - I'm just getting the uploaded image. This is the error message:

    (ERROR @ /root/core/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 154 || Image: assets/images/used/upright/File 1.JPG
    Could not cache thumbnail to file at: /root/folder/image-cache/images/used/upright/File 1.987503d0.jpg
    Resizer debug output:
        [0] => Resizer v1.0.1
        [1] => Using GD
        [2] => GD: assets/images/used/upright/File 1.JPG may exceed available memory  ** Skipping **


    Image sizes are not overly large at around 50kb. Image paths all look correct.

    This question has been answered by chrisandy. See the first response.

      Web site design in Nottingham UK by Chris Fickling http://www.chrisficklingdesign.co.uk
    • The server settings for memory use in a process is set lower than the image file you are processing, or the processor thinks it is and there is a bug.

      Have you searched google to see if other people are report this same error?

      What is the max process memory set to?

      Check the size of the image against the maximum allowed process memory to make sure that isn't the trigger first. Then, post the results.
      • discuss.answer
        Hi aaronkent - thank you for replying to this - I must admit, I forgot that I'd put it on here. It turned out to be something quite interesting. When upgrading to PHP7 with my particular host, the server memory limit setting got changed to -1. This doesn't appear to work with Resizer / pThumb so I added a local php.ini file to set the memory limit and this fixed it. With thanks to MarkH on the Slack channel for pointing me in the right direction.
          Web site design in Nottingham UK by Chris Fickling http://www.chrisficklingdesign.co.uk