Subscribe: RSS
  • Hi,

    I have a new 2.6.5 site that is up and running fine. I have now added MIGX to make a gallery easier to manage. However, although the MIGX grid appears as it should in the Template Variables tab, when I click on "Add Item" the window pops up and hangs (see attached image).

    There are no errors on either server error log or the MODX error log to give a clue. I have cleared the MODX cache manually and the browser cache. I have also re-installed MIGX.

    I have used MIGX before on several sites (earlier versions) and not had this issue, so I was wondering if there a bug with this latest version or can anyone suggest a fix for this?

    Many thanks - Mark.

    MIGX 2.12.0-pl
    MODX 2.6.5
    PHP 5.6.37
    MySql 5.6.39
    Apache 2.4.34


    • Any errors in the console of the browser?

      Quote from: zaphodx at Sep 04, 2018, 05:13 PM
      Hi,

      There are no errors on either server error log or the MODX error log to give a clue. I have cleared the MODX cache manually and the browser cache. I have also re-installed MIGX.

      • Hi,

        Thanks for your interest.

        Yes, in my further investigations I am finding that it is the entire page that is not rendering correctly, with is this set of errors showing up in the console:

        --

        unreachable code after return statement[Learn More] manager:515:2

        TypeError: this.mask.addClass is not a function[Learn More] modx.jsgrps-min.js:4:17838

        onShow
        http://xxxx.co.uk/manager/assets/modext/modx.jsgrps-min.js:4:17838

        afterShow
        http://xxxx.co.uk/manager/assets/ext3/ext-all.js:21:375922

        show
        http://xxxx.co.uk/manager/assets/ext3/ext-all.js:21:375343

        show
        http://xxxx.co.uk/manager/assets/ext3/ext-all.js:21:387123

        onAjaxException
        http://xxxx.co.uk/manager/assets/modext/core/modx.js:122:13

        fire
        http://xxxx.co.uk/manager/assets/ext3/ext-all.js:21:3690

        fireEvent
        http://xxxx.co.uk/manager/assets/ext3/ext-all.js:21:680

        handleFailure
        http://xxxx.co.uk/manager/assets/ext3/ext-all.js:21:51276

        f
        http://xxxx.co.uk/manager/assets/ext3/adapter/ext/ext-base.js:21:18130

        m
        http://xxxx.co.uk/manager/assets/ext3/adapter/ext/ext-base.js:21:18302

        createCallback/<
        http://xxxx.co.uk/manager/assets/ext3/adapter/ext/ext-base.js:21:8602

        unreachable code after return statement[Learn More] tinymce.panel.js:107:8

        unreachable code after return statement[Learn More] manager:515:2

        unreachable code after return statement[Learn More] modx.panel.resource.tv.js:32:8

        Source map error: request failed with status 404
        Resource URL: http://xxxx.co.uk/manager/assets/modext/modx.jsgrps-min.js
        Source Map URL: modx.jsgrps-min.js.map[Learn More]

        --

        This does not mean that much to me, although I have looked at the "Learn More" pages and understand it from a basic priciples point of view. I am guessing that the first error is probably giving rise to the subsequent errors.
        • It can not find modx.jsgrps-min.js.
          Sounds like a misconfiguration or something went wrong with the installation of MODX.
          Did you try to reinstall it? Cleaning the cache afterwards (/core/cache/)?
          • Looking at the file manager/assets/modext/modx.jsgrps-min.js, the function "onShow" looks like this:

            onShow:function(){if(this.el.hasClass("x-window-dlg"))this.mask.addClass("fade-in"),this.el.applyStyles({opacity:1});else{this.addClass("anim-ready");var win=this;setTimeout(function(){void 0!==win.mask&&(win.mask instanceof Ext.Element?win.mask.addClass("fade-in"):win.mask.el.addClass("fade-in")),win.el.addClass("zoom-in")},250)}},


            I'm guessing that there is something not right about this, but not being a js coder I can't see the problem with it.
            • Sorry I've been away from this a while, other priorities prevailed!

              I've re-installed both MODX and the MIGX extra but to no avail.

              The odd thing about not being able to find "modx.jsgrps-min.js", is that it then goes on to give errors on lines in that file, so it must be able to see it at some point.

              Also, I've created a test resource, one with nothing on it but the MIGX extra/tv (no FOUNDATION and no 3rd party gallery script), in case there was a clash of function/variable names. The problem still exists, it doesn't occur with any resources without MIGX.

              I also tried uninstalling TinyMCE in case is was causing any problems but no change.

              Further investigation seem to indicate that the whole manager page is not renering properly when the "Add Item" button is clicked. And interestingly, when I click on MIGX in the Extras menu, the page renders momentarily and then gets replaced by a blank page with just a strip of pale grey along the top.

              Still no idea what the overall cause is... [ed. note: zaphodx last edited this post 4 months, 1 week ago.]