New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • This is a weird one. . .

    While in process of troubleshooting why a newly installed extra was not working, we determined that the components files normally found in:

    assets/components/name of extra

    Were actually in:

    components/name of extra (same level as the assets folder)

    In fact there were several other extras in the same folder. In the assets/components folder there were a couple of folders that were also in the other folder (a few duplicates).

    I moved all the /component folders into the assets/components folders, which doesn't seem to affect any of those extras, but the newly installed extra still doesn't work.

    So I manually cleared the cache and reinstalled the new extra and found it created a new /components folder at the same level as the /assets folder rather than below it. I installed another new extra, to be sure the behaviour was not specific to one extra. It also put the files in the /component folder and it is also not working.

    I've checked the config file, the assets path is correct. I checked the modx_workspace table in the DB that looks fine as well. The modx error log doesn't shed any light.

    So I'm stumped.

    Why would new extras not get put into the /assets/components folder? Where is this controlled?
    Why would the previously installed extras work in that folder, when newly installed extras do not.
    Why would the previously installed extras continue to work when I moved those files from the /components folder into the /assets/components folder?

    Modx 2.6.5
    PHP 2.5.6

    Any ideas?
    • Check the MODX_ASSETS_PATH setting in core/config/config.inc.php. It looks like somewhere your assets path is coming up empty.
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/MODx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
      • Thanks Bob!

        I looked at that several times and didn't see the problem. Yes, it was indeed missing from the path statement.

        I'm good to go now.

        Thanks!