We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 31902
    • 342 Posts
    Willi Waizenegger Reply #1, 8 years, 1 month ago
    After a recent upgrade to 2.6.5, I experienced the White Screen of Death in the manager; the front of the site works normally. All used to work before the upgrade. I've done the usual fixes with no positive results (not necessarily in this order and some repeatedly):

    1. Clear core/cache multiple times.
    2. Check that compress_js/css are turned off.
    3. Flipped between PHP 7.0 and PHP 5.6.
    4. While set to PHP 7.0, I did the fix located on this page: https://forums.modx.com/thread/98914/having-trouble-running-modx-on-php-7-0-0-rc7.
    5. Re-ran setup.
    6. Re-installed.
    7. Cleared browser cache and checked in Incognito Mode (Chrome) or Private Mode (Firefox).
    8. Nothing in server error log having to do with MODx.
    8. Repeatedly bashed my forehead against my monitor.

    I'd appreciated any more thoughts on this. Thanks in advance.

    This question has been answered by waizen. See the first response.

    [ed. note: waizen last edited this post 8 years ago.]
      • 3749
      • 24,544 Posts
      Check the config.core.php file in the manager directory, and the MODX_MANAGER_PATH setting in core/config/config.inc.php to make sure the path to the manager is correct. In config.inc.php, check the connectors path too. That's the one most likely to be wrong.

      Check the error log file: core/cache/logs/error.log

      Watch the Network tab and the Console tab in Dev. tools (Ctrl-shift-i). On the network tab, you can click on a processor call (to connectors/index.php) and see the Header (scroll down all the way) and the Response.

      At the upper right of the Dev tools section, you'll see a red indicator if there are JS errors and the error will show on the console tab.

      If none of that works, you may have a widget, plugin, or snippet that's works in the Manager but is not happy. Try the other stuff first, though.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 31902
        • 342 Posts
        Willi Waizenegger Reply #3, 8 years, 1 month ago
        Thanks for responding, Bob,

        In the error log file at core/cache/logs/error.log, I see this:

        text/plain error.log ( ASCII text )
        
        [2018-08-21 09:49:46] (ERROR @ /home/username/public_html/core/cache/includes/elements/modsnippet/55.include.cache.php : 117) PHP warning: require_once(/home/username/public_html/core/components/upgrademodx/model/upgrademodx.class.php): failed to open stream: No such file or directory
        [2018-08-21 10:10:11] (ERROR @ /home/username/public_html/core/model/modx/modmanagerresponse.class.php : 190) PHP warning: Parameter 1 to modManagerController::getInstance() expected to be a reference, value given
        [2018-08-21 10:10:13] (ERROR @ /home/username/public_html/core/model/modx/modmanagerresponse.class.php : 190) PHP warning: Parameter 1 to modManagerController::getInstance() expected to be a reference, value given
        [2018-08-21 10:10:58] (ERROR @ /home/username/public_html/core/model/modx/modmanagerresponse.class.php : 190) PHP warning: Parameter 1 to modManagerController::getInstance() expected to be a reference, value given
        [2018-08-21 10:14:44] (ERROR @ /home/username/public_html/core/model/modx/modmanagerresponse.class.php : 190) PHP warning: Parameter 1 to modManagerController::getInstance() expected to be a reference, value given
        [2018-08-21 10:32:24] (ERROR @ /home/username/public_html/core/model/modx/modmanagerresponse.class.php : 190) PHP warning: Parameter 1 to modManagerController::getInstance() expected to be a reference, value given
        [2018-08-21 10:36:29] (ERROR @ /home/username/public_html/core/model/modx/modmanagerresponse.class.php : 190) PHP warning: Parameter 1 to modManagerController::getInstance() expected to be a reference, value given
        
        ...etc for many more...


        Note that the top error entry possibly looking for upgrademodx. I had, at one point, taken it out to do the upgrade manually. I'm assuming that entry isn't pointing to the cause of this 500 error, right?

        ~ Console tab in Chrome Dev Tools shows nothing. No changes at all. The page in Chrome showing a 500 error instead of white screen of death in Firefox.
        ~ config.core.php showing correct entries.
        ~ Within config.inc.php, those entries you spoke of look like this (except for the changed usernames). Note that I had left the config.inc.php file alone since this was an upgrade to 2.6.5 and not an install:

        if (!defined('MODX_CONNECTORS_PATH')) {
            $modx_connectors_path= '/home/username/public_html/connectors/';
            $modx_connectors_url= '/connectors/';
            define('MODX_CONNECTORS_PATH', $modx_connectors_path);
            define('MODX_CONNECTORS_URL', $modx_connectors_url);
        }
        if (!defined('MODX_MANAGER_PATH')) {
            $modx_manager_path= '/home/username/public_html/changedmanagername/';
            $modx_manager_url= '/changedmanagername/';
            define('MODX_MANAGER_PATH', $modx_manager_path);
            define('MODX_MANAGER_URL', $modx_manager_url);
        }



          • 27708 MODX Staff
          • 2,502 Posts
          Hi Willi,

          Do you by chance have either QuickStartButtons or Google Analytics Dashboard Widget installed?

          Are you able to append your Manager URL with ?a=system/settings and reach the System settings screen? If so, try to go to System>Dashboard and Update Dashbaord on the Default Dashboard (via right click) and right-click on the QSB or GA Widget to Remove it. Of course this may not be the cause of your issues.
            Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. Blog ✦ Twitter ✦ LinkedIn ✦ GitHub
            • 3749
            • 24,544 Posts
            Be sure to read Jay's note above.

            The UGM message in the log is a warning, not an error, but it's quite possible that UGM is trashing the Manager, especially if the UGM widget snippet is still there (or still in the cache) but it's files are missing.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 31902
              • 342 Posts
              Willi Waizenegger Reply #6, 8 years, 1 month ago
              Thank you, Jay and Bob, for helping out. Really appreciated.

              Jay, appending had no effect. However, is that the kind of thing that can be done through the database; through phpMyAdmin? If so...and please refer to the screen capture attached...am I in the right spot? Would I need to click on the delete link in the bigbrother.name entry?

              As you'll notice, I do have Big Brother installed.
                • 31902
                • 342 Posts
                Willi Waizenegger Reply #7, 8 years, 1 month ago
                Oh, and Bob, from the screen shot, I have a feeling UpgradeMODx may still be installed...not sure. This hacking has my head blurred between a whole bunch of sites.
                  • 3749
                  • 24,544 Posts
                  Yes, it looks like UpgradeMODX is still at least partially installed.

                  You don't want to change that table because in another table (modx_dashboard_widget_placement), MODX has the idea that those widgets need to be found and placed on the dashboard. When the widget record is not found MODX will freak out. So leave that table alone.

                  You want the modx_dashboard_widget_placement table. Delete all records in it. That won't remove the widgets themselves, but it will take them off all dashboards. Then manually delete all files in the core/cache directory before trying to log in. Your widgets will still exist and you can try putting them back on the dashboard (in System -> Dashboards -> Widgets) one at a time until you find the culprit.


                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 31902
                    • 342 Posts
                    Willi Waizenegger Reply #9, 8 years, 1 month ago
                    Quote from: BobRay at Aug 22, 2018, 02:26 PM

                    ...

                    You want the modx_dashboard_widget_placement table. Delete all records in it. That won't remove the widgets themselves, but it will take them off all dashboards. Then manually delete all files in the core/cache directory before trying to log in. Your widgets will still exist and you can try putting them back on the dashboard (in System -> Dashboards -> Widgets) one at a time until you find the culprit.

                    Bummer. Still no login screen. 500 error on Firefox. White screen on Chrome. Thank you for your patience, Bob.
                      • 46886
                      • 1,154 Posts
                      what php version are you running if I may ask? it might be unrelated but php can rear its head sometimes