New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • After a site got infected recently I have got a clean 2.6.5 install running with everything apart from the Gallery images are not displaying.
    The path is:
    <img src="/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=200&h=200&zc=1&far=C&q=90&src=%2Fassets%2Fgallery%2F3%2F75.jpg" alt="myImage.jpg" class="lazy">
    I have the extra pThumb installed. I'm not sure if i might be missing another extra?
    Anyone know?

    I also get a blank page when accessing areas of the Manager, Resources, Plugins, Chunks etc. I can just see some content in the top left - see attached screen shot.
    I have renamed the Manager and Connectors directories and also moved the Core directory and renamed it.
    The error log is as follows:
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/170.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/66.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/59.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/62.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/144.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/68.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/61.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/60.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/64.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/63.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/65.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/67.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/69.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/70.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/72.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/73.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/71.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/149.jpg  *** Skipping ***
    [2018-08-17 08:38:04] (ERROR @ /home/website/public_html/pathto/coredirectory/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 50 || Image: (none)
    File not found: /home/website/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=/assets/gallery/2/169.jpg  *** Skipping ***
    [2018-08-17 08:47:32] (ERROR @ /home/website/public_html/pathto/coredirectory/model/modx/transport/modtransportpackage.class.php : 385) Could not open file for reading: provisioner-1.1.0-pl.transport.zip?revolution_version=Revolution-2.6.5-pl
    [2018-08-17 08:47:32] (ERROR @ /home/website/public_html/pathto/coredirectory/model/modx/transport/modtransportpackage.class.php : 672) Could not retrieve from provisioner-1.1.0-pl.transport.zip?revolution_version=Revolution-2.6.5-pl
    [2018-08-17 08:47:32] (ERROR @ /home/website/public_html/pathto/coredirectory/model/modx/transport/modtransportpackage.class.php : 435) MODX could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
    [2018-08-17 08:47:32] (ERROR @ /home/website/public_html/pathto/coredirectory/model/modx/transport/modtransportpackage.class.php : 208) Could not transfer package provisioner-1.1.0-pl.transport.zip to /home/website/public_html/pathto/coredirectory/packages/.
    

    This question has been answered by 9thwave. See the first response.

    [ed. note: 9thwave last edited this post 6 months ago.]
      www.9thwave.co.uk
         WEB | DESIGN | PRINT
    • UPDATE: The blank Manager pages are now displaying although i'm not entirely sure what action made it work. I reinstalled a few Extras and am manually clearing the core/cache directlty constantly so it's all or one of these actions.

      The Gallery extra is still not working as it should.
      When I click on a Gallery page on the front end of the website the following error is generated...

      [2018-08-21 14:59:35] (ERROR @ /home/phillips/public_html/pathto/core/components/phpthumbof/model/phpthumbof.class.php : 156) [pThumb] Resource: 49 || Image: (none)
      File not found: /home/phillips/public_html/assets/components/gallery/connector.php?action=web/phpthumb&ctx=web&w=900&h=500&zc=0&far=&q=90&src=https://www.myWebsite.com/assets/gallery/1/145.jpg  *** Skipping ***


      The image definitely exists in the correct directory. I have pThumb installed along with Resizer.
      When I select Gallery from the Extras menu none of the existing albums are displaying and the 'Refresh' button is not clickable. Hovering over the 'Create Album' button gives a path to 'mailto:info@myWebsite.com'!!
      I have reinstalled the Gallery extra twice now.

      Anyone have any ideas?

        www.9thwave.co.uk
           WEB | DESIGN | PRINT
      • Try running the Gallery without any plugins. Just upload pics and see if it works. Maybe the plugins you use (resizer and pthumb) aren't compatible.
        • Thx @Stefany. I literally only have Gallery installed on a clean install. There is nothing else.
          I'm going to try a local setup to see if that's any different and will report back.
            www.9thwave.co.uk
               WEB | DESIGN | PRINT
          • Quote from: 9thwave at Aug 22, 2018, 09:27 AM
            Thx @Stefany. I literally only have Gallery installed on a clean install. There is nothing else.
            I'm going to try a local setup to see if that's any different and will report back.

            So weird. Do report back!
            • Couldn't get it to work:-/
              I have decided to use ModMores Gallery instead.
              I have now got a clean install where i have been installing database tables one by one (_htmlSnippets,_siteContent, _tmpl, tmplvars etc.).
              I thought everything was working OK but when i try to update a resource or create a new resource the manager screen disappears. I've attached 2 screen shots to demonstrate.
              When I try to update a migx section on a resource the following errors are generated and the screen goes as per the attached screen shots when i click on 'update' on the migx tv entry.
              [2018-08-24 11:53:20] (ERROR @ /home/mySite/public_html/modx-2.6.5/core/model/phpthumb/phpthumb.class.php : 1686) PHP warning: getimagesize(/home/mySite/public_html/modx-2.6.5/images/Simple Balm Product Photographer.jpg): failed to open stream: No such file or directory
              [2018-08-24 11:53:20] (ERROR @ /home/pmySite/public_html/modx-2.6.5/core/model/phpthumb/modphpthumb.class.php : 144) phpThumb was unable to generate a thumbnail for: /home/pmySite/public_html/modx-2.6.5/core/cache/phpthumb/www.mySite.com__src08c0bb01d1296d6f78fc126490d4ffef_parfe75230c38c1dd77cfb659e43ae25583_dat0.jpeg
              [2018-08-24 11:53:20] (ERROR @ /home/mySite/public_html/modx-2.6.5/core/model/phpthumb/modphpthumb.class.php : 156) Error outputting thumbnail:
              OutputThumbnail() failed because !is_resource($this->gdimg_output) in file "phpthumb.class.php" on line 618

              One other issue is that the Articles extra posts are not displaying in the Manager - they are on the website though.
              I'm lost as to what to do:-/
              [ed. note: 9thwave last edited this post 5 months, 4 weeks ago.]
                www.9thwave.co.uk
                   WEB | DESIGN | PRINT
              • I think this may be related to the same issue I am having. I found that downloading all the images that don't show up in image browser and resaving without extra data (save for web in Photoshop) fixes the thumbnails and the blank page. I don't know if a MODX issue or a system GD/Imagick issue though.
                • Hi @pyrographics,
                  I have tried everything on my server and there were lots of issues with the Manager in addition to Gallery images not displaying.
                  I have just deployed the site and first sql dump on the Modx Cloud and it worked first time!!
                  I'll contact my hosts to see if they can find any issues with the account on their server and report back.
                    www.9thwave.co.uk
                       WEB | DESIGN | PRINT
                  • discuss.answer
                    Turns out it was a permissions issue on the assets directory. Once changed from 775 to 755 and a manual cache clearing everything worked.
                    So pleased it's finally sorted but can't believe it was something so simple!
                      www.9thwave.co.uk
                         WEB | DESIGN | PRINT