⚠️ Urgent! Active Attacks on MODX Revolution Sites Below Revolution 2.6.5
Subscribe: RSS
  • Hello, all. My site was a victim of the pre-2.6.5 hacks. I reinstalled MODX (upgraded to 2.6.5 but was still hacked so reinstalled) and uninstalled and reinstalled all components including Article 1.7.11.pl. However, to my great horror, when I go to Manager and click on my archive resource, nothing appears in the Manager page. I've tried restoring my pre-reinstallation database and that does not help. How do I get my ability to create and edit my archive back? Thanks.
      http://www.spiritualoutreach.com
      Making Christianity intelligible to secular society
    • Is the page completely blank or is it the grid of articles that is missing?

      If the articles are missing I've had experience of two situations...

      1. You have a htaccess file in your assets directory that is blocking access.

      2. Try changing the default number of articles to show and provided condition 1 isn't the case, they may well all show up. Doing a search for a particular article may also make them show up.
        Web site design in Nottingham UK by Chris Fickling http://www.chrisficklingdesign.co.uk
      • Thanks for such a prompt reply. Alas, the page is completely blank. Not even the page information section is visible - absolutely nothing but the left margin navigation. What do I do in that case?
          http://www.spiritualoutreach.com
          Making Christianity intelligible to secular society
        • Basics first: Have you tried logging in via a different browser to make sure this isn't a browser caching issue?

          After that try inspecting the page in Chrome and check the console to see if you have any errors.
            Web site design in Nottingham UK by Chris Fickling http://www.chrisficklingdesign.co.uk
          • Quote from: chrisandy at Aug 12, 2018, 11:08 AM
            Basics first: Have you tried logging in via a different browser to make sure this isn't a browser caching issue?

            After that try inspecting the page in Chrome and check the console to see if you have any errors.

            Thank you for the suggestion. I had cleared cache and have tried in both Chrome and Firefox (running on Debian 9.5). I'll have a look at the console when I return.
            This is one of three major problems I have after reinstalling. Flexibility 5 either mangles my page layout or deletes my customizations depending on which database copy I use (pre or post reinstallation) and my Rich Text editor is gone in Manager no matter how I set the RTE settings. I don't know if these are related. Thanks again.
              http://www.spiritualoutreach.com
              Making Christianity intelligible to secular society