On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I'm currently having a problem with using a friendly url of the same name on my website. I built the resources before setting up friendly URLs and accidentally made one capital ex: About instead of about. I'm unable to change the alias or freeze the uri to the lowercase version and any attempt to access the page either with a lowercase link ex:site.com/about with the friendly url lowercase setting gives me a 404 error. I am still able to access the page by changing it to a capital. I'm wondering if the Resource name is stored anywhere locally on the server or if there is any workaround for this.

    Thanks in Advance
    • You should just be able to change the alias field to lowercase. What happens when you change it and save? Does it revert back to the capital version? Have you cleared cache and refreshed URIs ?
        ■ email: lk@alienbuild.uk | ■ website: https://alienbuild.uk

        The greatest compliment you can give back to us, is to spend a few seconds leaving a rating at our trustpilot: https://uk.trustpilot.com/review/alienbuild.uk about the service we provided. We always drop mention of services offered by businesses we've worked with in the past to those of interest.
      • Once you've successfully changed the alias, you can add a rewrite rule in .htaccess to forward from 'About' to 'about'.

        This plugin would also redirect users from 'About' to 'about'. It assumes that all aliases are lowercase: https://bobsguides.com/caseinsensitiveurls.html.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
        • Quote from: lkfranklin at Mar 28, 2018, 08:08 AM
          You should just be able to change the alias field to lowercase. What happens when you change it and save? Does it revert back to the capital version? Have you cleared cache and refreshed URIs ?

          Once the alias field is changed to lowercase and saved the site will try and redirect the traffic to the lowercase url but the site itself will serve a 404 page. changing the url to a capital will serve the correct page. I've cleared the cache (both by the button and deleting the whole folder on the server) and refreshed the URIs with no luck so far.
          • Quote from: BobRay at Mar 28, 2018, 06:30 PM
            Once you've successfully changed the alias, you can add a rewrite rule in .htaccess to forward from 'About' to 'about'.

            This plugin would also redirect users from 'About' to 'about'. It assumes that all aliases are lowercase: https://bobsguides.com/caseinsensitiveurls.html.


            Thanks for the plugin! I went to my site today and am now having a problem with the page redirecting back to the homepage (I have yet to install the plugin at this point). The url is now changing to site.com/?about= instead of the site.com/about expected. Any idea as to why?
            • Just tried after installing the plugin and same error: it'll return to the homepage with the address bar site.com/?about=. Is there any way to modify the database to serve the correct page? This is the only resource not working.
              • You might try editing the resource, clicking on the Freeze URI option (on the Settings tab), and putting whatever URL you want there, then saving it and clearing the cache.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                • Quote from: BobRay at Mar 29, 2018, 05:10 AM
                  You might try editing the resource, clicking on the Freeze URI option (on the Settings tab), and putting whatever URL you want there, then saving it and clearing the cache.

                  I've tried that, unfortunately I'm getting the same result. I did also modify the content types to remove the .html ending on the URL but changing it back again gives me a 404 error (even with the plugin). The page is a container based off the collection plugin if that helps at all.
                  • That's an odd one. If you freeze the URI and enter that URI in your browser, you should see the page, not a 404.

                    This almost has to be a MODX permissions problem.

                    If you make yourself a sudo user and clear the cache manually, do you see the resource?

                    Does the resource belong to any resource groups? If so, does removing it from all groups and clearing the cache manually make it show up?

                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                    • Quote from: BobRay at Mar 29, 2018, 08:32 PM
                      That's an odd one. If you freeze the URI and enter that URI in your browser, you should see the page, not a 404.

                      This almost has to be a MODX permissions problem.

                      If you make yourself a sudo user and clear the cache manually, do you see the resource?

                      Does the resource belong to any resource groups? If so, does removing it from all groups and clearing the cache manually make it show up?



                      It doesn't look like it's apart of any resource groups next to the root website group. I've used Cpanel to clear the cache along with being a sudo user but to no avail. I attempted with both URI freezing and keeping the standard alias lowercase. I also attempted to reinstall modx core through the same process as upgrading to see if that'd help with anything. If it's a permissions problem I can't find it. For now I'll do a temporary URI change to something else to get the page visible again.