We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 33657
    • 128 Posts
    I have a folder structure like...

    /home/zurie/public_html/

    i have an additional modx in an "addon" domain. so when you goto mynewurl.com it goes to a SUBFOLDER that is inside my public_html root.

    /home/zurie/public_html/submodxsite

    the problem is that in that addon domain site in that folder, when i try to install an addon, i get a endless loop where it cannot successfully find the /connectors/ folder. even though the site seems to be properly setup.

    Is there anything I can do to remedy the situation?

    If i leave the Install running i get a CXS malware trigger for a potential malicious act (since its endlessly looping ultra fast with a post request,etc)

    Time: Thu Mar 8 10:15:56 2018 -0500
    IP: MY IP HERE
    Failures: 5 (mod_security)
    Interval: 3600 seconds
    Blocked: Permanent Block [LF_MODSEC]

    Log entries:

    [Thu Mar 08 15:08:04.883946 2018] [:error] [pid 29376:tid 140030670497536] [client MYIPHERE:60519] [client MYIPHERE] ModSecurity: Access denied with code 403 (phase 2). Operator GE matched 5 at TX:anomaly_score. [file "/etc/apache2/conf.d/modsec_vendor_configs/OWASP3/rules/REQUEST-949-BLOCKING-EVALUATION.conf"] [line "30"] [id "949110"] [msg "Inbound Anomaly Score Exceeded (Total Score: 5)"] [severity "CRITICAL"] [tag "application-multi"] [tag "language-multi"] [tag "platform-multi"] [tag "attack-generic"] [hostname "mysite.com"] [uri "/connectors/index.php"] [unique_id "WqFR1PqT0ALzfM-waoA3JgAAAIk"], referer: http://mysite.com/manager/index.php?a=workspaces

    This question has been answered by zurie. See the first response.

      • 33657
      • 128 Posts
      also i get a error log of this

      [2018-03-08 15:15:43] (ERROR @ /home/zurie/public_html/mysubdomainsite/core/model/modx/modmanagerresponse.class.php : 190) PHP warning: Parameter 1 to modManagerController::getInstance() expected to be a reference, value given
      [2018-03-08 16:02:00] (ERROR @ /home/zurie/public_html/mysubdomainsite/core/xpdo/om/xpdoobject.class.php : 240) Error 42S22 executing statement: 
      Array
      (
          [0] => 42S22
          [1] => 1054
          [2] => Unknown column 'modUser.createdon' in 'field list'
      )
        • 17301
        • 932 Posts
        If you're looking to install a separate modx installation so that it is accessible from a subdomain, or even another domain completely, then you should setup a different hosting environment to cater for that.

        Additionally you could look into setting up multiple contexts to manage various sites from the one modx manager - where you would point all domains to the same document route for example.

        That being said I do have a lab that holds various development sites within different subfolders and that works fine. Ensure that each has their own htaccess file and that the core/config paths are setup correctly.
          ■ email: [email protected] | ■ website: https://alienbuild.uk

          The greatest compliment you can give back to us, is to spend a few seconds leaving a rating at our trustpilot: https://uk.trustpilot.com/review/alienbuild.uk about the service we provided. We always drop mention of services offered by businesses we've worked with in the past to those of interest.
          • 33657
          • 128 Posts
          Quote from: lkfranklin at Mar 08, 2018, 10:41 AM
          If you're looking to install a separate modx installation so that it is accessible from a subdomain, or even another domain completely, then you should setup a different hosting environment to cater for that.

          Additionally you could look into setting up multiple contexts to manage various sites from the one modx manager - where you would point all domains to the same document route for example.

          That being said I do have a lab that holds various development sites within different subfolders and that works fine. Ensure that each has their own htaccess file and that the core/config paths are setup correctly.

          right i have the same thing.. other installations that seem ok. but a few that are not happy and all of those few are "addon domains" that are inside the ROOT public_html folder. it seems that WHM / CPANEL now does addon domains OUTSIDE of root, so maybe thats why..

          ext-base.js:21 GET http://mysite.com/connectors/?_dc=1520527689662&action=workspace%2Fpackages%2FgetAttribute&attributes=license%2Creadme%2Cchangelog%2Csetup-options%2Crequires&signature=upgrademodx-1.5.5-pl&HTTP_MODAUTH=modx5aa15e8b102841.82994802_15aa15e980daca3.64192481 500 (Internal Server Error)
          i @ ext-base.js:21
          request @ ext-base.js:21
          request @ ext-all.js:21
          install @ package.grid.js:239
          onClick @ package.grid.js:219
          I @ ext-all.js:21
          11:48:09.835 ext-base.js:21 XHR failed loading: GET "http://mysite.com/connectors/?_dc=1520527689662&action=workspace%2Fpackages%2FgetAttribute&attributes=license%2Creadme%2Cchangelog%2Csetup-options%2Crequires&signature=upgrademodx-1.5.5-pl&HTTP_MODAUTH=modx5aa15e8b102841.82994802_15aa15e980daca3.64192481".
            • 33657
            • 128 Posts
            as soon as i click the Install on the addon that i want i get

            Request URL:https://mysite.com/connectors/index.php
            Request Method:POST
            Status Code:403 Forbidden
            Remote Address: removeIPaddressHere:443
            Referrer Policy:no-referrer-when-downgrade
              • 33657
              • 128 Posts
              looks like its MOD_SECURITY. and advice?

              2018-03-08 16:47:01	mysite.com	myIPADDRESSHERE	CRITICAL	404	
               942170: Detects SQL benchmark and sleep injection attempts including conditional queries  Hide
              Request:	POST /connectors/index.php
              Action Description:	Warning.
              Justification:	Pattern match "(?i:(?:(select|;)\\s+(?:benchmark|if|sleep)\\s*?\\(\\s*?\\(?\\s*?\\w+))" at ARGS:handler.
              • discuss.answer
                • 33657
                • 128 Posts
                Ok I fixed it by downloading ConfigSecurity ModSecurity manager for WHM and temporarily disabling Mod_Securty on that subdomain. it installed fine. just something to consider and possibly a reason why WHM now puts addon domains outside the ROOT of the main domain.

                mark this as resolved.