⚠️ Urgent! Active Attacks on MODX Revolution Sites Below Revolution 2.6.5
Subscribe: RSS
  • Hi,

    I have just done a clean install of MODX 2.6.1, replacing a much older site. As this is an all new site it seemed easier just to have a fresh start, so I backed up the old site and its DB, deleted it and the DB from the server and started again. However, although the new install seemingly works and the site works there is an issue with changes not showing up, they are visible in the manager but the pages don't update in the browser. I have cleared caches in both MODX and multiple browsers on multiple devices but the pages still don't show changes. Here's the weird thing: if I have a chunk that already appears on a page and then I change the chunk, if I create a new resource and add the chunk to it, it displays the change, whereas older resources don't, so two resources are displaying the same chunk differently. The same thing happens with templates. I keep thinking I am missing something obvious here but can't think what is causing this, any insughts or suggestions would be very much appreciated.

    The site is also using Foundation 6 framework.

    Cheers - Mark.

    This question has been answered by zaphodx. See the first response.

    • It really sounds like a browser cache issue. I can't think of anything else that would explain it. Try visiting the site with your browser in private or incognito mode.

      You can also try adding a dummy parameter at the end of the URL to convince the browser not to load the page from its cache.

      http://yoursite.com/some_page.html? x=22 



      I assume that you've tried manually deleting all files in the MODX core/cache directory.
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/MODx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
      • Hi Bob,

        Thank you for your input. I have tried all of those suggestions to no avail. I have also had a look at the chunks and templates in the database itself in case that wasn't getting updated correctly, but everything looks good there. I've also run your SiteCheck extra which showed no errors and checked both MODX and the server's error logs which showed nothing either.

        I have also found that if I delete the content of the template or change to a different template the page doesn't change in the browser, using multiple browsers on multiple devices.

        Could this be caused if there was something wrong with the .htaccess file? I have Friendly URLs "on".



        Thanks - Mark. [ed. note: zaphodx last edited this post 7 months, 4 weeks ago.]
        • I turned Friendly URLs off and the problem has gone, so I'm guessing the .htaccess file may be the problem, but it looks OK to me.
          • discuss.answer
            It was the .htaccess file. The old one from the previous site was still there, doh!