On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • RSS feed not working and receiving this error in the log.

    Any ideas?

    [2018-01-04 18:11:05] (ERROR @ /var/www/vhosts/ultimusfundsolutions.com/httpdocs/core/model/modx/modparser.class.php : 453) You should not call uncached elements inside cached!
    Outer tag: [[pdoResources? &parents=`0` &tpl=`ufsRSSItemE` &class=`ufsEvents` &loadModels=`ufsevents` &where=`{"published:=":"1","eenddate:<=":"[[!now]]"}` &fastMode=`0` &showLog=`0` &sortby=`eenddate` &sortdir=`ASC`]]
    Inner tag pdoResources? &parents=`0` &tpl=`ufsRSSItemE` &class=`ufsEvents` &loadModels=`ufsevents` &where=`{"published:=":"1","eenddate:<=":"[[!now]]"}` &fastMode=`0` &showLog=`0` &sortby=`eenddate` &sortdir=`ASC`

    Server and install details:

    OS: CentOS Linux 7.4.1708 (Core)
    Apache web server
    PHP 7.0.24
    Database server:
    Server: Localhost via UNIX socket
    Server version: 5.5.56-MariaDB - MariaDB Server
    nginx/1.11.10

    Modx 2.6.1-pl
    packages installed:
    ActivationEmail
    Breadcrumbs
    ClassExtender
    Collections
    FileLister
    FirstChildRedirect
    FormIt
    Gallery
    getReqParam
    Login
    MIGX
    pdoTools
    Personalize
    Rampart
    ReCaptchaV2
    Redactor
    SimpleSearch
    StageCoach
    • I'm not sure this will help, but here's how I did it:

      https://bobsguides.com/blog.html/2013/08/19/create-an-rss-feed-for-your-articles-blog/

      The &parents property could be set to any parent.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
      • This is using a MIGX configuration to pull from, thats why it's using pdoResouces rather than getResources. The feed has been working for over a year until the recent Modx updates. I did try using your method of getResources, which removes the error but the feed still doesn't work.
        • Got the error to go away by placing a bang! in front of pdoResources. Unfortunately, the feed still doesn't want to pull data from the Migx configuration.
          • W. Shawn Wilkerson Reply #5, 1 year, 5 months ago
            You could try spiefeed in the repository. It always worked for me.

              Get your copy of MODX Revolution Building the Web Your Way http://www.sanitypress.com/books/modx-revolution-building-the-web-your-way.html

              Check out my MODX || xPDO resources here: http://www.shawnwilkerson.com
            • For web searchers researching this error:

              I found a more trivial cause for this error, we had a chunk that an updater person had copied in wrong: [[$chunkname?value=`something`]

              They'd left off the closing ]. That then tripped a huge modx error log, with all the rest of the page template html logged, and of course, nothing after that error printed in the html of the page.

              Finding this is very difficult, I was very lucky because the rest of the template html contained a pointer in the html to which page it was, otherwise I would never have been able to find it. [ed. note: lizardx last edited this post 1 year, 3 months ago.]
              • I wonder if this would cause the same problem:

                 [[$chunkname?value=`something`] ]


                I just mentally wrote a check that would test the page and chunk content for these:

                if (substr_count($content, '[[') !== substr_count($content, ']]') {
                   /* Error */
                }
                


                If I find time, maybe I'll build it into SiteCheck.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting