On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Have a timeline on a site using Migx, but content isn't showing. This error is populating in the log "Could not load class: pdofetch from pdotools.pdofetch." Is this somehow related?

    Server and install details:

    OS: CentOS Linux 7.4.1708 (Core)
    Apache web server
    PHP 7.0.24
    Database server:
    Server: Localhost via UNIX socket
    Server version: 5.5.56-MariaDB - MariaDB Server
    nginx/1.11.10

    Modx 2.6.1-pl
    packages installed:
    ActivationEmail
    Breadcrumbs
    ClassExtender
    Collections
    FileLister
    FirstChildRedirect
    FormIt
    Gallery
    getReqParam
    Login
    MIGX
    pdoTools
    Personalize
    Rampart
    ReCaptchaV2
    Redactor
    SimpleSearch
    StageCoach

    This question has been answered by stortzdesignteam. See the first response.

    • did you try to reinstall pdoTools?
        -------------------------------

        you can buy me a beer, if you like MIGX

        http://webcmsolutions.de/migx.html

        Thanks!
      • Yes and I got this in the reinstall log:
        Skipping vehicle object of class modSystemSetting (data object exists and cannot be upgraded); criteria: Array ( [key] => pdoTools.class )
        Skipping vehicle object of class modSystemSetting (data object exists and cannot be upgraded); criteria: Array ( [key] => pdoFetch.class )
        Skipping vehicle object of class modSystemSetting (data object exists and cannot be upgraded); criteria: Array ( [key] => pdoParser.class )
        Skipping vehicle object of class modSystemSetting (data object exists and cannot be upgraded); criteria: Array ( [key] => pdotools_fenom_default )
        Skipping vehicle object of class modSystemSetting (data object exists and cannot be upgraded); criteria: Array ( [key] => pdotools_fenom_parser )
        Skipping vehicle object of class modSystemSetting (data object exists and cannot be upgraded); criteria: Array ( [key] => pdotools_fenom_php )
        Skipping vehicle object of class modSystemSetting (data object exists and cannot be upgraded); criteria: Array ( [key] => pdotools_fenom_modx )
        Skipping vehicle object of class modSystemSetting (data object exists and cannot be upgraded); criteria: Array ( [key] => pdotools_fenom_options )
        Skipping vehicle object of class modSystemSetting (data object exists and cannot be upgraded); criteria: Array ( [key] => pdotools_fenom_cache )
        Skipping vehicle object of class modSystemSetting (data object exists and cannot be upgraded); criteria: Array ( [key] => pdotools_fenom_modifiers )
        • you could try to remove all pdoTools - system settings before reinstalling or try to remove pdoTools completely and install fresh again
            -------------------------------

            you can buy me a beer, if you like MIGX

            http://webcmsolutions.de/migx.html

            Thanks!
          • removed pdo and deleted pdo system settings, reinstalled with no errors, but still not displaying content.
            • discuss.answer
              Did a review of all the entries for the timeline and noticed a blank one, removed and seemed to have fixed the problem. Thanks for your help with the pdo issue.