On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hello!

    I have an issue when I upgrade MODX version 2.5.8 to 2.6.0.

    Following error came up when I login from manager.

    Fatal error: Uncaught --> Smarty Compiler: Syntax error in template "4a7144ff3309b09d49b1370ba45cd5f4cab2847e" on line 80 "'success': {fn:function() { location.href = './'; },scope:this}" - Unexpected ":", expected one of: "}" <-- thrown in /home/mysite/public_html/core/model/smarty/sysplugins/smarty_internal_templatecompilerbase.php on line 80

    Upgrade went fine and no errors there, site works fine also.

    Server details:
    - Apache 2.2.23
    - PHP 7.0
    - MySQL 5.5.51

    Cache is emptied and I have tried different browser too. Earlier upgrades went also great, this is the first time when I have this kind of issue. What should I do to access manager again?

    Thank you advance!

    Best regards,
    Tom

    This question has been answered by tom333z. See the first response.

    • I'd suggest running setup again.

      If that doesn't work, I'd download the .zip file for the new version locally, extract the files, Then zip up the Manager folder, upload it to the site, and extract the files. Then run setup again. Manually delete all files in the core/cache directory before logging in.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
      • Hello BobRay!

        Thank you for your help.

        I did all from ground and install new clean MODX 2.6.0. After that I move all needed backup files including assets/components + core/components + core/packages. Finally database backup back to the server and now all runs fine.

        Only these Manager sections on mainpage "MODX News Feed" shows Loading... and "MODX Security Feed" Loading...

        Also frontend Twitter feed Loading tweets... This works on earlier MODX 2.5.8 version. Maybe these are javascript issues, who knows?

        Best regards,
        Tom
        • Can you open your browser console while the MODX dashboard is loading and see if there are any javascript errors?
            I'm lead developer at Digital Penguin Creative Studio in Hong Kong. https://www.digitalpenguin.hk
            Check out the MODX tutorial series on my blog at https://www.hkwebdeveloper.com
          • You can go to System (gear icon) -> System Settings and put 'feed' (without the quotes) in the search box. Then you can turn off those feeds.

            It sounds like an issue with connecting to external sites. Can you install packages in Package Manager?

            If you haven't already, try visiting the site with your browser in private or incognito mode to make sure it's not a leftover cookie or browser cache file that causing the problems.

            The suggestion above to watch the console in Chrome Dev. tools or Firebug (Ctrl-shift-i) is a good one. Also, watch the Network tab as the Manager page is loading.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
            • Quote from: muzzstick at Dec 03, 2017, 07:00 AM
              Can you open your browser console while the MODX dashboard is loading and see if there are any javascript errors?

              Thank you for your suggestion. I did Console check with Firefox and it gives me the following message.

              [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (modx.jsgrps-min.js.map, line 0)
              http://www.site.com/manager/assets/modext/modx.jsgrps-min.js.map


              Best regards,
              Tom
              • discuss.answer
                Thank you BobRay!

                I did these following as you suggest.

                Quote from: BobRay at Dec 03, 2017, 09:28 PM
                You can go to System (gear icon) -> System Settings and put 'feed' (without the quotes) in the search box. Then you can turn off those feeds.
                There was "Yes" checked. I check these "No" then clean cache and turn them back "Yes". No effect.

                It sounds like an issue with connecting to external sites. Can you install packages in Package Manager?
                I install SiteCheck and run test. There is some errors "Checking Encoding and Collation for all text columns" example https://d.pr/i/RBTxNZ, some errors with "Transport Packages" example https://d.pr/i/sllDoA and some errors with "modTemplateVarResources" example https://d.pr/i/2gzdhk

                If you haven't already, try visiting the site with your browser in private or incognito mode to make sure it's not a leftover cookie or browser cache file that causing the problems.
                I try different browser and after this also first time with iPhone/Safari. No effect.

                The suggestion above to watch the console in Chrome Dev. tools or Firebug (Ctrl-shift-i) is a good one. Also, watch the Network tab as the Manager page is loading.
                I did this and got this error message.
                [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (modx.jsgrps-min.js.map, line 0)
                http://www.site.com/manager/assets/modext/modx.jsgrps-min.js.map


                One stupid question about htaccess file. I have following parameters in htaccess and "max-age=2678400, private" in .js

                I don't know if this could be the answer, but I allready tried without htaccess without success.

                <IfModule mod_headers.c>
                  <filesmatch "\.(ico|flv|jpg|jpeg|png|gif|css|swf)$">
                  Header set Cache-Control "max-age=2678400, public"
                  </filesmatch>
                  <filesmatch "\.(html|htm)$">
                  Header set Cache-Control "max-age=7200, private, must-revalidate"
                  </filesmatch>
                  <filesmatch "\.(pdf)$">
                  Header set Cache-Control "max-age=86400, public"
                  </filesmatch>
                  <filesmatch "\.(js)$">
                  Header set Cache-Control "max-age=2678400, private"
                  </filesmatch>
                </IfModule>


                Best regards,
                Tom
                • I don't think the .htaccess stuff is in issue.

                  I was suggesting that you leave the feeds off.

                  Is this file there? /manager/assets/modext/modx.jsgrps-min.js.map

                  How did you put the 2.6.0 files in place?

                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting