We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 15558
    • 108 Posts
    Hi everybody,


    I just had to proceed to this update and - sorry for this - I just can't remember what version I was upgrading from.

    Installation went totally fine, but now I encounter a problem : I can't access to the manager.

    Parse error: syntax error, unexpected ')' in /homepages/xx/xxxxx/htdocs/manager/controllers/default/security/login.class.php on line 293

    That line 293 begins with :
    () {
            return 'security/login.tpl';
        }


    indeed, I see no login.tpl at all.


    I have no clue how to resolve this. Can somebody help me please ? I cleared core/cache, if you need to know - it didn't help...

    This question has been answered by BobRay. See the first response.

      Sorry for that ⇧ , I'm no dev but I wanna try
    • discuss.answer
      • 3749
      • 24,544 Posts
      My guess is that that login class file is either corrupted or out-of-date. Did you use the UpgradeMODX extra to upgrade?

      If you transferred the new files individually with FTP, that often results in missing or corrupted files.

      I would suggest moving that file again (if necessary, manually downloading the Login extra package locally, extracting it, and putting that class file in place on the site). Manually delete the cache files again before trying to log in.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 15558
        • 108 Posts
        Thank you BobRay, your answer is kind of a solution, i mean by that after reuploading that given file, the error disappeared, then another came up. Again, i re-uploaded the newly concerned file, and so on, bouncing from error to another error until I get Parse errors like

        Fatal error: Uncaught Error: Call to a member function get() on array in /homepages/24/xxxx/htdocs/manager/controllers/default/resource/resource.class.php:152 Stack trace: #0 /homepages/24/xxxx/htdocs/core/model/modx/modmanagercontroller.class.php(158): ResourceManagerController->firePreRenderEvents() #1 /homepages/24/xxxx/htdocs/core/model/modx/modmanagerresponse.class.php(74): modManagerController->render() #2 /homepages/24/xxxx/htdocs/core/model/modx/modmanagerrequest.class.php(180): modManagerResponse->outputContent(Array) #3 /homepages/24/xxxx/htdocs/core/model/modx/modmanagerrequest.class.php(128): modManagerRequest->prepareResponse() #4 /homepages/24/xxxx/htdocs/manager/index.php(58): modManagerRequest->handleRequest() #5 {main} thrown in /homepages/24/xxxx/htdocs/manager/controllers/default/resource/resource.class.php on line 152

        which I can't fix by applying the former advice.


        I suspect my problem has to do with replacing manually the files via FTP - although I took very care of not replacing the folders but to merge them, I used Transmit 5 for that.
        At first I unzipped modx-2.5.8-pl.zip on the server, but wasn't given the choice to merge those files/folders with the old ones (struggled to know why and still don't know). I only could do this by unzipping locally and uploading them : at that point, I was able to merge all of this. (What would happen if I chose now to replace the files instead of merge them ?)

        And... how do I get out of this ? sad thanks for your help
          Sorry for that ⇧ , I'm no dev but I wanna try
          • 15558
          • 108 Posts
          Well, I tried this several times with no luck : and again, I re-re-re-uploaded the whole /manager folder and re-setup the update and it works now fine. Such a waste of time. Thank you Bob for your help.
            Sorry for that ⇧ , I'm no dev but I wanna try
            • 3749
            • 24,544 Posts
            I'm glad you got it sorted. In future, please consider the UpgradeMODX extra which will download the new files (in a .zip file), extract them, and overwrite the existing files for you.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 15558
              • 108 Posts
              will do ! thanks
                Sorry for that ⇧ , I'm no dev but I wanna try