On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • My client is running revo version 2.3.3 (I know I need to upgrade after this issue). The website is not displaying properly: http://www.skywardltd.com/

    According to the client, they were working on the contacts page only adding a new employee before their site went down. But the website looks like there is a larger issue at play, other than just a POSSIBLE messed up HTML page edited from a non-webmaster in the admin resources page tree. I do have all pages, templates and chunks backed up from a year ago.

    The error logs have this many times over from 2016-12-28 - 2017-8-14:
    /SERVER PATH HERE/xpdo/xpdo.class.php : 3043) SQLSTATE[HY000] [2006] MySQL server has gone away


    Yet the front end of the website shows invalid certificate. The backup they have is over a year old, so I want to see if I can remedy this before contacting their hosting company about a possible backup. Where should I look first to see why this website is not showing?
      Making the web a better place on site at a time! Dayton Web Design: http://www.dayton-web-design.com/
    • Site is back up. Kept going back to why the HTTPS setting was turned on, where there is no security certificate installed. Turns out under system settings this key:
      URL Generation Scheme
      was set to -1. I changed the setting to http and now the site shows fine.

      But it still does not explain why I the reoccurring error in my error logs:
      /SERVER PATH HERE/xpdo/xpdo.class.php : 3043) SQLSTATE[HY000] [2006] MySQL server has gone away
        Making the web a better place on site at a time! Dayton Web Design: http://www.dayton-web-design.com/
      • It could just be that your server's DB is overloaded, especially if it's a shared server.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
        • Thanks BobRay. The hosting platform they are using is Network Solutions so your assessment is probably spot on. At least from my experience their servers are always slow especially during peak hours.

          Earlier today I loaded the site in my browser and it showed a blank homepage. Immediately, reloaded the page and the site was showing normally. So I wouldn't be surprised if their database and or server files has performance issues or are overused. I suppose this is the price for using Network Solutions.
            Making the web a better place on site at a time! Dayton Web Design: http://www.dayton-web-design.com/
          • when the server is overloaded, the speed may drop, but this is a temporary phenomenon. Maybe problems with the hosting? I first moved the site to a hosting, but he hung up, then gave errors. But it was found only through the monitoring service https://www.host-tracker.com/, the notification came that the site is falling, and it turned out that my hosting in black lists, so there were problems. Try to follow your site through the service, if there are errors, it will automatically restart the engine on the hosting. It's convenient.