New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • I have a website that is working fine with YAMS on localhost.

    I tried to copy YAMS to another website on localhost but language tabs don't display, everything seems same. I missed something, but what ?

    Solution: the mm_rules chunk was missing. (see 4th post below about how to set it)

    Here's what I have done:
    - copy of the assets/modules/yams folder
    - adapted yams.config.inc.php and .htaccess for the new website
    - created the multilingual TVs
    - installed the YAMS module, created multilingual variables, set multilingual templates
    - set the YAMS plugin and associated the following events:
    Template Service Events
    
    Template Service Events
    =======================
    OnLoadWebDocument
    OnParseDocument
    OnWebPageInit
    OnWebPagePrerenderer
    
    Cache Service Events
    ====================
    OnLoadWebPageCache
    
    PageServiceEvents
    =================
    OnPageNotFound
    
    Documents
    =========
    OnBeforeDocFormSave

    As I was not sure if required, I also installed ManagerManager and configured it like for the other site.

    It seems from the "Server Config" tab of the YAMS module, that the server config is not content of the .htaccess at the root of the site, like if some version had been cached.

    Any idea?

    This question has been answered by Jul. See the first response.

    [ed. note: Jul last edited this post 1 year, 4 months ago.]
    • HI,

      do you have the same modx version on both sites ?
      do you have manager manager installed on the target site ?
      did you get the last update of YAMs on the repository ?

      hope this help
      Eric.
      • Hi,

        Thanks.

        Yes, 1.0.15 on both sites.
        Yes, ManagerManager was installed on the target site too.
        Version of YAMS for both sites is the 1.2.0 RC3.
        • discuss.answer
          After several attempts, the problem was solved.
          Missing mm_rules chunk was preventing the tabs to work.

          mm_rules chunk must have the following content:
          require( $modx->config['base_path'] . 'assets/modules/yams/yams.mm_rules.inc.php' );