On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • We are planning to migrate two websites with Evo 1.0.4 and 1.0.5 versions to a new server (with dual PHP configuration), running on PHP 5.3.x Before doing that I'd like to know the compatibility of these versions with PHP 5.3.x, and if I can expect problems with a more modern version of mysql for example.

    Can anybody advise me on this subject?

    This question has been answered by iusemodx. See the first response.

    • discuss.answer
      In theory YES they will work, but they won't work with 5.4+ or 7

      You shouldn't be using those versions anymore due to security issues

      From 1.0.15 the mysql extension was removed, it now uses mysqli
      • Thanks,

        I understand the security issues of PHP 5.3.x, thats why my server is using 5.6.x and in due time 7.x. These new customers, however, come from a server that will be shut down. There is not enough time to upgrade before that time so we configure the Dual PHP on our server and proceed like that until the site upgrades are done. Thanks again! Reyn

        Quote from: iusemodx at Sep 06, 2017, 08:29 AM
        In theory YES they will work, but they won't work with 5.4+ or 7

        You shouldn't be using those versions anymore due to security issues

        From 1.0.15 the mysql extension was removed, it now uses mysqli