On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Potentially, but usually if the API isn't validated it won't render the recaptcha box or will display a clear error about the auth key and domains.

    I'd suggest reverse engineering your form by stripping out large chunks for testing purposes, or equally building out from a basic one field form with no validators and then add in the recaptcha, then the validation, hooks etc.

      ■ email: lk@alienbuild.uk | ■ website: https://alienbuild.uk

      The greatest compliment you can give back to us, is to spend a few seconds leaving a rating at our trustpilot: https://uk.trustpilot.com/review/alienbuild.uk about the service we provided. We always drop mention of services offered by businesses we've worked with in the past to those of interest.
    • discuss.answer
      Quote from: lkfranklin at Aug 31, 2017, 11:45 AM
      Potentially, but usually if the API isn't validated it won't render the recaptcha box or will display a clear error about the auth key and domains.

      I'd suggest reverse engineering your form by stripping out large chunks for testing purposes, or equally building out from a basic one field form with no validators and then add in the recaptcha, then the validation, hooks etc.

      Hi, I have tried it on a live server and guess what, there works like it is supposed to work, but I have no idea why, have to figure it out somehow for future testing purposes, thank you for your help!
      • Possibly reCaptcha doesn't accept 'localhost' as a valid domain.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
        • Glad you got it sorted none the less.. I think Bob is correct

          localhost domains are no longer supported by default. If you wish to continue supporting them for development you can add them to the list of supported domains for your site key. Go to the admin console to update your list of supported domains. We advise to use a separate key for development and production and to not allow localhost on your production site key.
            ■ email: lk@alienbuild.uk | ■ website: https://alienbuild.uk

            The greatest compliment you can give back to us, is to spend a few seconds leaving a rating at our trustpilot: https://uk.trustpilot.com/review/alienbuild.uk about the service we provided. We always drop mention of services offered by businesses we've worked with in the past to those of interest.
          • Additionally I believe you also need to access localhost via 127.0.0.1 rather than 'localhost'
              ■ email: lk@alienbuild.uk | ■ website: https://alienbuild.uk

              The greatest compliment you can give back to us, is to spend a few seconds leaving a rating at our trustpilot: https://uk.trustpilot.com/review/alienbuild.uk about the service we provided. We always drop mention of services offered by businesses we've worked with in the past to those of interest.
            • Quote from: lkfranklin at Sep 01, 2017, 06:56 AM
              Additionally I believe you also need to access localhost via 127.0.0.1 rather than 'localhost'
              I have tried both options before, none of it was working :/
              • discuss.answer
                Different day, different problem smiley Today I have set my smtp settings for gmail in system settings and guess what, mails are not sending due to error. But on localhost it is working. So i have checked different topics regarding that, it usually helps if you add a hook '&emailFrom' so I have added this, it is not working. Also i have installed QuickEmail package for better diagnosis. I have tried changing the tls/ssl 587/465 options

                I get this error:

                2017-09-01 11:11:12 SMTP ERROR: Failed to connect to server: Connection refused (111)
                • discuss.answer
                  It might be worth creating a new topic for that query as this one is now marked as answered so people who check for support questions may not see this. Also it helps future users with the same issue.
                    ■ email: lk@alienbuild.uk | ■ website: https://alienbuild.uk

                    The greatest compliment you can give back to us, is to spend a few seconds leaving a rating at our trustpilot: https://uk.trustpilot.com/review/alienbuild.uk about the service we provided. We always drop mention of services offered by businesses we've worked with in the past to those of interest.
                  • You may have to set gmail to allow 'connections from less secure apps'.

                    https://support.google.com/accounts/answer/6010255?hl=en

                    Although I see this is not possible if you have two factor authentication enabled for the the gmail account.
                      If I help you out on these forums I would be very grateful if you would consider rating me on Trustpilot: https://uk.trustpilot.com/review/andytough.com

                      email: andy@andytough.com | website: https://andytough.com
                    • Quote from: lkfranklin at Sep 01, 2017, 11:18 AM
                      It might be worth creating a new topic for that query as this one is now marked as answered so people who check for support questions may not see this. Also it helps future users with the same issue.
                      I just don't want to open new discussions and spam everywhere...

                      Quote from: andytough at Sep 01, 2017, 12:43 PM
                      You may have to set gmail to allow 'connections from less secure apps'.

                      https://support.google.com/accounts/answer/6010255?hl=en

                      Although I see this is not possible if you have two factor authentication enabled for the the gmail account.

                      This option was already enabled, because the mails are sent on localhost, just not on live server, currently I'm in contact with host provider, maybe there are some firewall settings not allowing smtp go through... I'll report.