On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hi there!

    I installed the blox1.2.3-extra via the package management (MODX 2.5.7).

    blox is giving me some output with this call:

    [[!bloX?
    	&packagename=`inserate` 
    	&classname=`Inserate` 
    	&sortConfig=`[{"sortby":"RAND()"}]` 
    	&where=`{"published":"1"}
    	&tpls=`row:InserateBilder`
    ]]
    
    


    But the "tpls"-part seems to be ignored, I got the same output with or without the tpls. The chunk "InserateBilder" exists.

    Secondly I can't find any chunks or anything else in the backend/manager. I also refreshed, logged out and flushed sessions. Somewhere in the forum i read about missing elements in the resource-tree (i can't find the thread atm), but the suggestion there was to use Bob Rays "SiteCheck", which i did use...it found a few errors which I could get rid of by hand. But still no chunks etc. showing up.

    I also deinstalled and reinstalled blox, without success.

    Last thing I tried was to edit the chunk files in the core/components/blox-folder, but this didn't change anything.

    At the moment I'm getting the pagination and the following:

    (32)
    (28)
    (34)
    ...

    So I can't edit the output at all...

    Any hint available on what i'm doing wrong?


    (modified for some more explanation) [ed. note: profilneurotiker last edited this post 2 years, 1 month ago.]
    • if you don't need anything special, what only bloX could do, I would suggest, using migxLoopCollection from MIGX - package.

      use it like that:

      [[!migxLoopCollection?
          &packageName=`inserate` 
          &classname=`Inserate` 
          &sortConfig=`[{"sortby":"RAND()"}]` 
          &where=`{"published":"1"}
          &tpl=`InserateBilder`
      ]]
      
        -------------------------------

        you can buy me a beer, if you like MIGX

        http://webcmsolutions.de/migx.html

        Thanks!
      • Thanks Bruno - once again - for your excellent and fast help!

        This is woorking with the code you provided...i thought i tried this earlier as well, but i might be wrong.

        But...I guess you can tell if there should be a blox-folder in chunks in the backend, shoudn't it? Otherwise, how am I able to edit the blox-output?y