Hi Guys,
Apologies for the first post being a question. I just migrated a site from a cpanel based hosting environment to another cpanel based server. Everything went fine except the contact form on the site, Which now give a 500 error whenever I press the submit button.
I tried updating the formit plugin from backend with no success.
Any help would be appreciated.
Is the email still being sent and recorded? It could be a couple of things but first try and find out if the form is still sending or not. Secondly if therer's a redirect in the call make sure the resource it's redirecting to works ok and then I'd say to check the base href and htaccess to make sure they're setup correctly.
You did run setup in the new location after moving the site, right?
I downloaded the latest modx package and ran the setup with upgrade option selected. Everything went smooth but the contact form still doesn't seem to work.
When I click "Submit" without typing anything on the form, it just gives me a 500 error. Looks like it is not able to process anything. Nothing is saved in the backend as well.
Any help would be appreciated.
Thanks
Do you have any hooks in the FormIt tag?
You might try SPForm. It's less flexible than FormIt, but easier to set up, imo.
If SPForm throws a 500 error, you'll know something really weird it going on.
Sounds a bit odd. Can you confirm it worked OK before the Migration? Confirmed that format is installed and present under the extras menu? Confirmed that all other extras are working OK?
I guess the next thing to do would be to post up your call and former to check for any errors, though that should be fine if it worked before. D