We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 49635
    • 63 Posts
    Hello!

    There was a small problem with the login to the admin panel. After substituting the wrong locale in the system settings. And also after the substitution of the locale in the configuration.
    After that, the locale was removed, but the problem remained.
    The problem at loading a manager

    Fatal error: Call to a member function getMessage() on string in /home/p441037/www/seo-sst.ru/core/model/modx/modmanagercontroller.class.php on line 616

    The problem at the time of updating СMS:

    Checking if /www/site_name/ directory exists: Failed!
    Checking if /www/site_name/manager/ directory exists: Failed!
    Checking if /www/site_name/connectors/ directory exists: Failed!

    The search did not work. How did the site break down for unknown reasons)

    This question has been answered by almag13. See the first response.

      • 49635
      • 63 Posts
      All url paths are verified there are no errors... Folder rights are also checked folders exist and rights are 775
        • 49635
        • 63 Posts
        Strange things, new details.

        <head>
        <base href="[[!++site_url]]" />
        ....
        </head>

        Displayed in html

        <head>
        <base href="http://site.com/site.com" />
        ....
        </head>

        That is, they began to be duplicated
          • 49635
          • 63 Posts
          ok. Have remodeled the simple ways to complete and the problem has disappeared ...
          As mentioned before, the system was updated with this way

          http://site.com/site.com/index.html

          And Disappeared bass url in the site head
            • 3749
            • 24,544 Posts
            Some of that could be caused by a missing or mismatched DOCTYPE, or invalid HTML in the Template.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 49635
              • 63 Posts
              Due to DOCTYPE and HTML The manager of the MODx does not start?
              And cause a fatal error?
                • 3749
                • 24,544 Posts
                Sorry, no -- not unless the Manager template has changed. When I saw your base href tag, I thought you were talking about the front end.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                • discuss.answer
                  • 49635
                  • 63 Posts
                  thx.
                  Problem in mo standart path for config.php on server.