Hello Everybody,
Two weeks ago I updated modx from 2.4.4 to 2.5.4.
Update went well, I thought, I can login into the manager and control things but I cannot open a page to change or make a new page, then I get a white page and nothing is happening.
How can I fix this?
Thanks in advance.
Diederick
Hello Diederick
Is there anything in the MODX error log?
Manage > Reports > Error log
Hello Andy,
The log list is verry long but the items after the update are:
[2017-01-17 14:27:46] (ERROR @ /home/baptisten/domains/pniel-baptisten.nl/public_html/core/model/modx/mail/phpmailer/class.phpmailer.php : 1442) PHP warning: escapeshellcmd() has been disabled for security reasons
[2017-01-17 14:28:04] (ERROR @ /home/baptisten/domains/pniel-baptisten.nl/public_html/core/model/modx/mail/phpmailer/class.phpmailer.php : 1442) PHP warning: escapeshellcmd() has been disabled for security reasons
[2017-01-18 13:03:22] (ERROR @ /home/baptisten/domains/pniel-baptisten.nl/public_html/core/xpdo/om/xpdoobject.class.php : 1452) Error 23000 executing statement:
INSERT INTO `modx_session` (`id`, `access`, `data`) VALUES ('ebd70ccf3c5f37459b4ef63205df9185', 1484741002, 'modx.user.contextTokens|a:0:{}')
Array
(
[0] => 23000
[1] => 1062
[2] => Duplicate entry 'ebd70ccf3c5f37459b4ef63205df9185' for key 'PRIMARY'
)
[2017-01-21 12:08:57] (ERROR @ /home/baptisten/domains/pniel-baptisten.nl/public_html/core/model/modx/mail/phpmailer/class.phpmailer.php : 1442) PHP warning: escapeshellcmd() has been disabled for security reasons
[2017-01-25 12:25:41] (ERROR @ /home/baptisten/domains/pniel-baptisten.nl/public_html/core/model/modx/mail/phpmailer/class.phpmailer.php : 1442) PHP warning: escapeshellcmd() has been disabled for security reasons
[2017-02-03 10:19:04] (ERROR @ /home/baptisten/domains/pniel-baptisten.nl/public_html/core/model/modx/modcachemanager.class.php : 344) Error caching lexicon topic lexicon/en/tinymce/default
[2017-02-03 10:19:04] (ERROR @ /home/baptisten/domains/pniel-baptisten.nl/public_html/core/model/modx/modcachemanager.class.php : 344) Error caching lexicon topic lexicon/nl/tinymce/default
Hello Andy,
I installed the backup of 2.4.4 and that is working well.
After the update to 2.5.4 again the same problem.
Error log is empty.
Did updates before the same way and always went well.
Any idea?
Hello Andy,
I solved the problem, I had to reinstall TinyMCE, It is working fine now.
Thanks everybody.