New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • Quote from: fourroses666 at Jan 30, 2017, 04:43 PM
    Have you selected Tinymce4 at the Config > interface page as editor?
    Yes of course
    • Had the same issue of TinyMCE4 not displaying in Evolution 1.2.

      Here's how I solved it:

      1) Downloaded the assets/plugins/tinymce4 folder from another site running EVO 1.4.5.
      (TinyMCE 4.7.4 instead of 4.3.7.2)

      2) Uploaded the assets/plugins/tinymce4 to my web hosting, to replace existing tinymce4 folder

      3) Replaced the TinyMCE source code by (notice the ".inc.php"):
      if (!defined('MODX_BASE_PATH')) { die('What are you doing? Get out of here!'); }
      require(MODX_BASE_PATH."assets/plugins/tinymce4/plugin.tinymce.inc.php");

      4) Applied Nicola (Banzai)'s trick:

      * Go to Tintymce4 plugin config
      * Scroll to the bottom of the config page
      * Introtext RTE
      add richtext-features to "introtext" > enable

      (Maybe step 4 would have suffice ; it would be to test.)

      This applies the Wysiwyg editor to both the introtext (and rich text TV as well).
      Not only to those fields, but magically also to the main "Content" area.
      The editor has kind of a minimalist style (not like TinyMCE 3).