This is an ongoing problem for me. If I move a Modx site to a new server the "validate" parameter in Formit causes a 500 error on submit.
Just a simple test on a form with one text input with a name "fullname" . This works fine...
But this throws an error on submit...
[[!FormIt? &validate=`fullname:required`]]
Everything else works fine... it's just this one problem. I've tried everything I can think of including clearing the cache manually, running set up over again, changing compression settings, removing all other plugin ins and re-installing just formit & still it doesn't work.
The only way I can get it to work is a fresh install of Modx and rebuilding the site, which is obviously very time consuming.
Does anyone have any other suggestions... please?