We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 52804
    • 36 Posts
    This is an ongoing problem for me. If I move a Modx site to a new server the "validate" parameter in Formit causes a 500 error on submit.

    Just a simple test on a form with one text input with a name "fullname" . This works fine...

    [[!FormIt]]
    


    But this throws an error on submit...

    [[!FormIt? &validate=`fullname:required`]]
    


    Everything else works fine... it's just this one problem. I've tried everything I can think of including clearing the cache manually, running set up over again, changing compression settings, removing all other plugin ins and re-installing just formit & still it doesn't work.

    The only way I can get it to work is a fresh install of Modx and rebuilding the site, which is obviously very time consuming.

    Does anyone have any other suggestions... please?

    This question has been answered by robh76. See the first response.

    • discuss.answer
      • 52804
      • 36 Posts
      Solved it (after many hours & days of frustration!) - Finally thought to check the PHP error log and found this:-

      Call to undefined function mb_strpos() in /home/xxxxxxxx/public_html/core/components/formit/model/formit/fivalidator.class.php on line 254

      Turns out the multibyte string extension is not enabled by default in some PHP applications (I'm running PHP on Centos 7). For WHM it can be resolved by going to the Software tab and selecting EasyApache4 and installing the multibyte extension from there.

      Hope this is helpful to someone out there!