On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hello,

    Thanks for your attention, from yesterday i get this message "Your host needs to use PHP 5.3.10 or higher to run this version of Joomla!", I'm not using Joomla, I use modx evolution 1.0.15, What does this mean?

    I updated the php version in my hosting to 5.3 but i get this error:

    Warning: require_once(/home/elranch6/public_html/includes/defines.php) [function.require-once]: failed to open stream: No such file or directory in /home/elranch6/public_html/index.php on line 89

    Fatal error: require_once() [function.require]: Failed opening required '/home/elranch6/public_html/includes/defines.php' (include_path='.:/opt/php53/lib/php') in /home/elranch6/public_html/index.php on line 89

    How can i solve this error?
    • Line 89 of index.php is specifying the database server and there is no includes folder in evolution as far as I know, are you sure you've uploaded the correct files / have the correct files on the server ?

      If this has just started happening what is the date for last modified for the index.php and is there a includes folder on the server ?
      • Paulp thanks for reply,

        Really I haven't made any change in the files or folders. But moments ago i get a message from google search console:

        Google has detected that your site has been hacked by a third party who created malicious content on some of your pages. This critical issue utilizes your site’s reputation to show potential visitors unexpected or harmful content on your site or in search results. It also lowers the quality of results for Google Search users. Therefore, we have applied a manual action to your site that will warn users of hacked content when your site appears in search results. To remove this warning, clean up the hacked content, and file a reconsideration request. After we determine that your site no longer has hacked content, we will remove this manual action.

        Following are one or more example URLs where we found pages that have been compromised. Review them to gain a better sense of where this hacked content appears. The list is not exhaustive.

        http://www.elranchodejonas.com/Tfj8845513/Qr315656/85636MS96.mhtml

        http://www.elranchodejonas.com/act/polo/21609-mashedp.htm

        http://www.elranchodejonas.com/clip/5134/ipa.htm

        My site was hacked, is it the cause of: Your host needs to use PHP 5.3.10 or higher to run this version of Joomla! or Warning: require_once(/home/elranch6/public_html/includes/defines.php) [function.require-once]: failed to open stream: No such file or directory in /home/elranch6/public_html/index.php on line 89

        Fatal error: require_once() [function.require]: Failed opening required '/home/elranch6/public_html/includes/defines.php' (include_path='.:/opt/php53/lib/php') in /home/elranch6/public_html/index.php on line 89

        ?
        • Download the latest version of Evo from https://modx.com/download/evolution/ and upload all files to your server, then run the installer in upgrade mode, that should hopefully bring the site back up. Change all passwords for manager users and the server. Your then going to have to go through the files removing all the ones that shouldn't be there which is a pain but necessary.

          To be honest we had 5 Evo sites hacked early last week and no matter what I did they kept getting back in and re hacking it, I've ended up removing those sites from the server all together.
          • @Paulp

            Have you patched the installs at all using the security patch that can be found on GitHub ?

            To also note is: The new version of Evo will be published shortly which is not only a security fix, it has tons of updated features including a new Manager layout and tools
            • Quote from: iusemodx at Nov 23, 2016, 09:25 AM
              @Paulp

              Have you patched the installs at all using the security patch that can be found on GitHub ?

              Yes, I patched all sites as soon as it was released but they still got in
              • The original patch wasn't enough, so if you read down the Github post you will find the information required, you also have to check the database for malicious code

                You can also read this post