We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 49814
    • 23 Posts
    hello,
    I'm running evo 1.04 (yesss, I know, but since it's modified from third party, I don't dare to upgrade...).
    I had an infection on several files; most of them newly written, so I just deleted them.
    Now the backend is working, the Homepage is working, but the (ditto-) subpages throw an 404-error.
    The files sidecache.idx.php and sitePublishing.idx.php were infected; in the first there was alien code.
    I cleaned it up, also tried with an very old version of the file (2010) - no cure.
    Is it possible that this file is the cause?
    There is a code hint with an error in this line, but it's the same line in the old 2010-file also:
    $ditto_base = isset($ditto_base) ? $modx->config[\'base_path\'].$ditto_base : $modx->config[\'base_path\']."assets/snippets/ditto/";


    I can have a backup restored, from 2 days ago - but it's not sure it was taken before the infection.

    This is the front end:
    http://www.buecher-pelzner.de

    Is there any help?
    Thnx
    Gertrud

    This question has been answered by wishbone. See the first response.

      • 49814
      • 23 Posts
      I actually don't think it is the mentioned code line, because the homepage works.
      This means it must have to do with a template. May be the ditto call?

      Or some file permissions?

      Only to give me a hint where to search...

      Thank you
      • discuss.answer
        • 49814
        • 23 Posts
        it was the .htaccess, stupid !!!