Quote from: robh76 at Oct 26, 2016, 12:22 PMI have just upgraded my server from Centos 6 to Centos 7 (php 5.6) and suddenly I have a problem with Formit validation. If I try and validate any fields the page returns a 500 error on submit. If I leave out the &validate=`` - It works fine. Has anyone else encountered this?
I've narrowed it down a bit. A fresh install of Modx on the new server and Formit works fine. However, when I move my development site to the new server if I include any validation in Formit, on form submit I get a blank white page in Firefox and a "500" error in Chrome. It works fine on the devlopment server and I've gone through the process for moving a site to the letter, including logging out, manually deleting the cache, running set up and everything checks out fine...
For test purposes, I have run this Formit call in both situations in a document with an empty Template. I works for the fresh install but not on the site I've moved...
[[!FormItRetriever]]
[[!+fi.fullname]]
[[!+fi.validation_error_message]]
[[!FormIt? &store=`1` &validate=`fullname:required`]]
<form action="[[~[[*id]]]]" name="myform" method="POST">
<input type="text" name="fullname" value="">
<input name="submit" type="submit" value="submit" >
</form>
Completely baffled....Any ideas?