We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 52804
    • 36 Posts
    I have just upgraded my server from Centos 6 to Centos 7 (php 5.6) and suddenly I have a problem with Formit validation. If I try and validate any fields the page returns a 500 error on submit. If I leave out the &validate=`` - It works fine. Has anyone else encountered this?

      • 52804
      • 36 Posts
      Quote from: robh76 at Oct 26, 2016, 12:22 PM
      I have just upgraded my server from Centos 6 to Centos 7 (php 5.6) and suddenly I have a problem with Formit validation. If I try and validate any fields the page returns a 500 error on submit. If I leave out the &validate=`` - It works fine. Has anyone else encountered this?


      I've narrowed it down a bit. A fresh install of Modx on the new server and Formit works fine. However, when I move my development site to the new server if I include any validation in Formit, on form submit I get a blank white page in Firefox and a "500" error in Chrome. It works fine on the devlopment server and I've gone through the process for moving a site to the letter, including logging out, manually deleting the cache, running set up and everything checks out fine...

      For test purposes, I have run this Formit call in both situations in a document with an empty Template. I works for the fresh install but not on the site I've moved...

      [[!FormItRetriever]]
      [[!+fi.fullname]]
      [[!+fi.validation_error_message]]
      
      [[!FormIt? &store=`1` &validate=`fullname:required`]]
      
      <form action="[[~[[*id]]]]" name="myform" method="POST">
      <input type="text" name="fullname" value="">
      <input name="submit" type="submit" value="submit" >
      </form>
      


      Completely baffled....Any ideas?
        • 10208 ☆ A M B ☆
        • 1,780 Posts
        When you moved the site, did you use a new yourDevVersionMODX.zip file? How was it unpacked and loaded onto the server?

        Even if you did use a new file, I'd suggest getting a new one anyway. I don't know how many times I've used the same file to reinstall or move a site more than once (wasting time) because I know I just downloaded it... only to grab a new one and suddenly everything is fine.
          Frogabog- MODX Websites in Portland Oregon
          "Do yourself a favor and get a copy of "MODX - The Official Guide" by Bob Ray. Read it.
          Having server issues? These guys have MODX Hosting perfected - SkyToaster
          • 52804
          • 36 Posts
          Quote from: frogabog at Oct 27, 2016, 11:34 PM
          When you moved the site, did you use a new yourDevVersionMODX.zip file? How was it unpacked and loaded onto the server?

          Even if you did use a new file, I'd suggest getting a new one anyway. I don't know how many times I've used the same file to reinstall or move a site more than once (wasting time) because I know I just downloaded it... only to grab a new one and suddenly everything is fine.

          Thanks... yes I did. The odd thing is I don't get the problem when I move the site to my old Centos 6 server. I gave up in the end and moved all the assets over manually onto a fresh install on Centos 7. I use XAMPP for development and something happens when I move the site from XAMPP to my live Centos 7 server which causes the problem with Formit.