We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 24629
    • 370 Posts
    Hi,
    I just did a fresh install of modx 2.5.1 on a new server. After the set up, that went fine (all green lights), i end up on the manager that gives me an 503 error.
    Anyone any ideas what could be wrong for this to happen??
    - there are NO php errors in the logs
    - PHP version 7.0 ()

    server:
    - PHP Version 7.0.8-0ubuntu0.16.04.2

    tnx
    RDG

    This question has been answered by rdaneeel. See the first response.

      • 38850
      • 110 Posts
      503 is odd. It's supposed to mean that the server is unable to respond, like it's in maintenance mode or overloaded or something. It's a temporary condition.

      You might want to check the server logs and performance numbers in case something is happening like out of RAM or drive space or CPU is maxed or some other condition, perhaps with MySQL too.

      Beside that, the only time I've got 5xx errors with MODX is due to .htaccess issues. If you need to rename the default htaccess file and edit it, try that.

      Otherwise this may be a server issue. It might even be PHP7. I've not ran MODX on PHP7 and haven't heard of any issues either.
      • discuss.answer
        • 24629
        • 370 Posts
        Hi,

        It turned out to be my ISP. seems OMDx needs to connect to the outside and some URLs where not whitelisted, also the guy recompiled php7 and i guess a few other cockups.
        So this was a case of ISP.

        tnx
        RDG