On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hello!
    I'm a site editor, total n00b. Today I just edited a main page. Changed content text from russian to Ukrainian (copy/paste). Then after saving I tried to preview and the error screen showed up.

    Error : Undefined offset: 0
    Error information
    ErrorType[num] NOTICE[8]
    File .../assets/snippets/evoBabel/evoBabel.class.php
    Line 250
    Source return $res[0];
    Current Plugin evoBabel(OnWebPageInit)

    Backtrace
    DocumentParser->executeParser()
    index.php on line 145
    DocumentParser->invokeEvent('OnWebPageInit')
    manager/includes/document.parser.class.inc.php on line 1720
    DocumentParser->evalPlugin(string $var1, array $var2)
    manager/includes/document.parser.class.inc.php on line 3716
    eval()
    manager/includes/document.parser.class.inc.php on line 1022
    evoBabel->__construct(DocumentParser $var1, 0, array $var3)
    manager/includes/document.parser.class.inc.php(1022) : eval()'d code on line 12
    evoBabel->getCurLangId(0)
    assets/snippets/evoBabel/evoBabel.class.php on line 36

    The site loads hell slow but show everything right in all languages. The evoBabelLexicon window in ModX is pale yellow and shows error:

    Error : Undefined variable: langs

    I don't think it is something terrible, but I'll probably be cut in half (tomorrow or next Monday) for messing up. Please help.
    Thanks.

    I use ModX Evo 1.1RC-d7.1.5 . This is some ukrainian dev edition.