<![CDATA[ Quick Manager Front end menu: Create resource here loads a blank screen after uprgrade t0 1.0.14 - MODX Community Forums]]> https://forums.modx.com/thread/?thread=91829 <![CDATA[Quick Manager Front end menu: Create resource here loads a blank screen after uprgrade t0 1.0.14]]> https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-501747
Since upgrading to 1.0.14 both the "create resource here" and "edit resource" buttons load a blank screen. The manager and log out options still work.

The only problem I had with the upgrade was in FTP'ing the file assets/plugins/managermanager/js/jsquery-1.9.1.min.js Everything else went completely smoothly.

The webserver is Microsoft IIS 6.0 and PHP 5.3.5 MYSQL 5

Any help will be much appreciated.





]]>
bishopweb Jun 29, 2014, 09:51 AM https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-501747
<![CDATA[Re: Quick Manager Front end menu: Create resource here loads a blank screen after uprgrade t0 1.0.14]]> https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-527284 redtoad Jun 22, 2015, 10:05 AM https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-527284 <![CDATA[Re: Quick Manager Front end menu: Create resource here loads a blank screen after uprgrade t0 1.0.14]]> https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-508132
Thanks for pointing out that MODxHost uses mootools.... I'm a bit more optimistic that if I upgrade my 20+ sites to 1.0.14 I may still be able to use QM with full Modal overlay.

Pretty sure I will run into other issues but I will give it a go and update here.

Thanks again.]]>
taiyo1578 Sep 05, 2014, 09:09 AM https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-508132
<![CDATA[Re: Quick Manager Front end menu: Create resource here loads a blank screen after uprgrade t0 1.0.14]]> https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-508131 with a fresh template it seems to work with the overlay.

BUT if you are using modxhost as a base...
Try adding jquery version into the script call order- (before the mootols call) , perhaps call it from the template folder (just add it that templates js library.). IF you do this then you will want to set your
QM PLUGIN CONFIG
- JqueryNoConflict mode back to TRUE
- and Modal Front end back to True

Do this and it may work. I got it working that way - locally
BUT unfortunately that set up does not work with a new template Im working on - (which I got the editor overlay working by doing opposite)

Try it now and see if that helps.
]]>
DfX Sep 05, 2014, 09:02 AM https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-508131
<![CDATA[Re: Quick Manager Front end menu: Create resource here loads a blank screen after uprgrade t0 1.0.14]]> https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-508129 Quote from: DfX at Sep 02, 2014, 02:03 PM
Thanks Gonna focus on the MM for a bit and also see if my tempalte has too many scripts that may be conflicting. However I do think QuickEdit is invaluable for many of my clients/friends. Its far easier to edit from the front end wits spots that have been designated for them as editable, but I concede it certainly is not a deal breaker..

I think it is a deal breaker. It is the one feature that I've sold to so many clients.]]>
taiyo1578 Sep 05, 2014, 08:05 AM https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-508129
<![CDATA[Re: Quick Manager Front end menu: Create resource here loads a blank screen after uprgrade t0 1.0.14]]> https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-508128
My biggest gripe is that this should be working by default with the default website that comes with the installation of 1.0.14. sad

]]>
taiyo1578 Sep 05, 2014, 08:03 AM https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-508128
<![CDATA[Re: Quick Manager Front end menu: Create resource here loads a blank screen after uprgrade t0 1.0.14]]> https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-508091 Plugin Config fo QM heres the whole thing if you just want to add..

&1=undefined;; &jqpath=Path to jQuery;text;assets/js/jquery-1.9.1.js &loadmanagerjq=Load jQuery in manager;list;true,false;false &loadfrontendjq=Load jQuery in front-end;list;true,false;false &noconflictjq=jQuery noConflict mode in front-end;list;true,false;false &loadtb=Load modal box in front-end;list;true,false;true &tbwidth=Modal box window width;text;80% &tbheight=Modal box window height;text;90% &hidefields=Hide document fields from front-end editors;text;parent &hidetabs=Hide document tabs from front-end editors;text; &hidesections=Hide document sections from front-end editors;text; &addbutton=Show add document here button;list;true,false;true &tpltype=New document template type;list;parent,id,selected;parent &tplid=New document template id;int;3 &custombutton=Custom buttons;textarea; &managerbutton=Show go to manager button;list;true,false;true &logout=Logout to;list;manager,front-end;manager &disabled=Plugin disabled on documents;text; &autohide=Autohide toolbar;list;true,false;false &editbuttons=Inline edit buttons;list;true,false;false &editbclass=Edit button CSS class;text;qm-edit &newbuttons=Inline new resource buttons;list;true,false;false &newbclass=New resource button CSS class;text;qm-new &tvbuttons=Inline template variable buttons;list;true,false;false &tvbclass=Template variable button CSS class;text;qm-tv


But Among other things You will notice that I updated the path to query-1.9.1.js (the min JQ I just took out .min part , I was previously using I think 1.45, I read that MM relies on 1.9... so that may have played a step I did have to copy that .js to there...

Plugin Execution Order: (relevant ones where both MM and Qm are called, I think...I added the "onBeforeDocFormSave: as a 'system event' to QM one of those... )
OnBeforeDocFormSave
MM
QM

OnDocFormPrerender
MM
QM

And Finally My Template was already calling Jquery, Since I wasn't sure which version ..I just made sure it was the same as what MM and QM rely on. So in this case - again I may have even copied over..
<script type="text/javascript" src="assets/templates/"YOURTEMPLATENAME"/js/jquery-1.9.1.js"></script>

I hope this helps at least a bit.
Ill check back at a later time to see if there is anything else I could share..

]]>
DfX Sep 04, 2014, 04:22 PM https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-508091
<![CDATA[Re: Quick Manager Front end menu: Create resource here loads a blank screen after uprgrade t0 1.0.14]]> https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-508081 Quote from: banzai at Sep 02, 2014, 02:36 PM
Try to enable/disable "Load jQuery in manager" and "Load jQuery in front-end" and try all combinations.


Changing these settings, depending on the site and the template, I always solved my QM issues

QM doesn't work with the default website which is baffling to me.... Can you share the combo that you got working?]]>
taiyo1578 Sep 04, 2014, 12:40 PM https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=3#dis-post-508081
<![CDATA[Re: Quick Manager Front end menu: Create resource here loads a blank screen after uprgrade t0 1.0.14]]> https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=2#dis-post-508077
QM is the #1 reason that I still have 20+ sites on Evo and not Revo.

Thanks.]]>
taiyo1578 Sep 04, 2014, 12:30 PM https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=2#dis-post-508077
<![CDATA[Re: Quick Manager Front end menu: Create resource here loads a blank screen after uprgrade t0 1.0.14]]> https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=2#dis-post-507866
I also think I found a typo..I think..not sure if it did anything but I did change this as well ,,,
In the 1.0.13 release of modx the qm inc line 114-

114:      $this->modx->sendRedirect($this->modx->makeUrl($id).'?quickmanagerclose=1', 0, 'REDIRECT_HEADER', 'HTTP/1.1 301 Moved Permanently'); 
                    }else{
116:                        $this->modx->sendRedirect($this->modx->makeUrl($id).'&quickmanagerclose=1', 0, 'REDIRECT_HEADER', 'HTTP/1.1 301 Moved Permanently');


changed (corrected?)
'?quickmanagerclose=1`
to
'&quickmanagerclose=1`]]>
DfX Sep 02, 2014, 10:29 AM https://forums.modx.com/thread/91829/editor-users-the-drop-down-menu-for-create-resource-here-results-in-blank-screen-after-upgrade-to-1-0-14?page=2#dis-post-507866