<![CDATA[ TinyMCE produces invalid xhtml with chunks - MODX Community Forums]]> https://forums.modx.com/thread/?thread=85667 <![CDATA[Re: TinyMCE produces invalid xhtml with chunks]]> https://forums.modx.com/thread/85667/tinymce-produces-invalid-xhtml-with-chunks#dis-post-480029 r.oder.ich Oct 11, 2013, 11:13 AM https://forums.modx.com/thread/85667/tinymce-produces-invalid-xhtml-with-chunks#dis-post-480029 <![CDATA[Re: TinyMCE produces invalid xhtml with chunks]]> https://forums.modx.com/thread/85667/tinymce-produces-invalid-xhtml-with-chunks#dis-post-473132 I can reproduce this behaviour, r.oder.ich has mentioned. I already had trouble with some projects because of that - now I know the reason.

I often provide my customers with a shortcut-kind-of chunk, that puts out a company name, e. g.
{{3v}} -> 3<span class="v">v</span>-immobilien


fourroses666's solution assumes, that a editor is able to create/modify chunks. This is forbidden in my concept of roles and rights and therefore no alternative.

A workaround is to place the chunk inside another tag, like
<p><span>{{someChunk}}</span></p>
or
<p><span>{{someChunk}}</span> Text here.</p>

But I then, I have to tell my customers to use the HTML-Editor... Better not. wink

I can also state, that this behaviour starts with 1.0.9 and wasn't there in 1.0.8. So, there might be some changes in TinyMCE implementation in the community driven MODx Evo.

Help will be highly appreciable, smiley
Chris.]]>
mr.odo Jul 26, 2013, 11:40 AM https://forums.modx.com/thread/85667/tinymce-produces-invalid-xhtml-with-chunks#dis-post-473132
<![CDATA[Re: TinyMCE produces invalid xhtml with chunks]]> https://forums.modx.com/thread/85667/tinymce-produces-invalid-xhtml-with-chunks#dis-post-473126 Quote from: fourroses666 at Jul 23, 2013, 10:53 AM

[*id:is=`99`:then=`{{someChunk}}`:else=``*][*content*]
but still tinyMCE shouldn't behave like this and it didn't before 1.0.9]]>
r.oder.ich Jul 26, 2013, 10:05 AM https://forums.modx.com/thread/85667/tinymce-produces-invalid-xhtml-with-chunks#dis-post-473126
<![CDATA[Re: TinyMCE produces invalid xhtml with chunks]]> https://forums.modx.com/thread/85667/tinymce-produces-invalid-xhtml-with-chunks#dis-post-472615
If not maybe you can use this?
[*id:is=`99`:then=`{{someChunk}}`:else=``*][*content*]
]]>
fourroses666 Jul 23, 2013, 10:53 AM https://forums.modx.com/thread/85667/tinymce-produces-invalid-xhtml-with-chunks#dis-post-472615
<![CDATA[TinyMCE produces invalid xhtml with chunks]]> https://forums.modx.com/thread/85667/tinymce-produces-invalid-xhtml-with-chunks#dis-post-472329
since Evo 1.0.9, there is a strange behaviour in tinyMCE. When inserting a line like
<p>{{someChunk}}</p>

it will discard the tags after saving.
Even worse when you write something like
<p>{{someChunk}} some text</p>

it will only remove the trailing tag which results in invalid xhtml.
Did anybody already encounter this bug or can reproduce it or even has a solution for this?

Regards
Roderich]]>
r.oder.ich Jul 19, 2013, 07:42 PM https://forums.modx.com/thread/85667/tinymce-produces-invalid-xhtml-with-chunks#dis-post-472329