<![CDATA[ Resource Not Saving - MODX Community Forums]]> https://forums.modx.com/thread/?thread=84093 <![CDATA[Re: Resource Not Saving]]> https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464920 BobRay May 01, 2013, 12:28 AM https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464920 <![CDATA[Re: Resource Not Saving]]> https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464866
Thanks.]]>
visualgui Apr 30, 2013, 09:19 AM https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464866
<![CDATA[Re: Resource Not Saving]]> https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464496
I just tried copying the code in a-new and pasting it back to a, but no luck. I even wiped out everything in template a and saved blank and still no luck.

The site is running MODX Evo 1.0.6; therefore, I wiped out everything in the assets/cache and still no luck.

I ran command lines to to repair and optimize databases (
mysqlcheck -Aor -u root -p
), still no luck. I even compare a and a-new in PhpMyAdmin and both look identical.

Is it possible that somehow template a's permission has changed? Is there a CHMOD permission for template inside the database?

My last resort I am thinking of is to upgrade MODX to 1.0.10 to see if that fixes the issue. Is that a good move?]]>
visualgui Apr 26, 2013, 11:01 PM https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464496
<![CDATA[Re: Resource Not Saving]]> https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464488
If that doesn't work, try going into PhpMyAdmin and repairing the DB tables.

Manually deleting all files in the core/cache directory might also be worth a try.
]]>
BobRay Apr 26, 2013, 10:23 PM https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464488
<![CDATA[Re: Resource Not Saving]]> https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464470 visualgui Apr 26, 2013, 02:27 PM https://forums.modx.com/thread/84093/resource-not-saving?page=2#dis-post-464470 <![CDATA[Re: Resource Not Saving]]> https://forums.modx.com/thread/84093/resource-not-saving#dis-post-464380
There's no different between the two other than their IDs. The codes are exactly the same. While changing to "a-new" works, I would prefer fixing "a" so that I don't have to change thousands of pages from "a" to "a-new."

Could someone advise on how to fix template "a"?

Thanks,]]>
visualgui Apr 25, 2013, 02:50 PM https://forums.modx.com/thread/84093/resource-not-saving#dis-post-464380
<![CDATA[Re: Resource Not Saving]]> https://forums.modx.com/thread/84093/resource-not-saving#dis-post-464337
No data received
Unable to load the webpage because the server sent no data.
Here are some suggestions:
Reload this webpage later.
Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.


I am not having a problem with just one resource, but all resources under one container (directory). I can't edit and can't delete any of those resources. It doesn't seem like saving gets input into the database. Please advise.

]]>
visualgui Apr 25, 2013, 08:08 AM https://forums.modx.com/thread/84093/resource-not-saving#dis-post-464337
<![CDATA[Re: Resource Not Saving]]> https://forums.modx.com/thread/84093/resource-not-saving#dis-post-464272 sottwell Apr 24, 2013, 11:49 PM https://forums.modx.com/thread/84093/resource-not-saving#dis-post-464272 <![CDATA[Re: Resource Not Saving]]> https://forums.modx.com/thread/84093/resource-not-saving#dis-post-464230 smashingred Apr 24, 2013, 04:46 PM https://forums.modx.com/thread/84093/resource-not-saving#dis-post-464230 <![CDATA[Re: Resource Not Saving]]> https://forums.modx.com/thread/84093/resource-not-saving#dis-post-464218
If it's just a single Resource, it's almost certainly modx_security. If you're curious, you can delete paragraphs one at a time until it goes away and, once you find the paragraph, delete a sentence at a time, then words in the offending sentence. Sometimes it's a command word like Select or delete. Other times, it's just a word your host doesn't like casino or viagra.]]>
BobRay Apr 24, 2013, 03:35 PM https://forums.modx.com/thread/84093/resource-not-saving#dis-post-464218