<![CDATA[ Не работает восклицательный знак в тегах - MODX Community Forums]]> https://forums.modx.com/thread/?thread=82727 <![CDATA[Re: Не работает восклицательный знак в тегах]]> https://forums.modx.com/thread/82727/#dis-post-564598 Бился с этой проблемой несколько дней.
Оказалось в меню Содержимое-->Типы содержимого поставил галочку на HTML "двоичный".
Прям ровно такая же проблема была, одна на весь интернет.
Может кому поможет, когда-нибудь )
]]>
tomgwarrior Mar 25, 2019, 08:19 PM https://forums.modx.com/thread/82727/#dis-post-564598
<![CDATA[Re: Не работает восклицательный знак в тегах]]> https://forums.modx.com/thread/82727/#dis-post-457319 Alroniks Mar 03, 2013, 02:02 PM https://forums.modx.com/thread/82727/#dis-post-457319 <![CDATA[Re: Не работает восклицательный знак в тегах]]> https://forums.modx.com/thread/82727/#dis-post-456913 Когда переустановил на modx-2.2.6-pl, при установке cms выбрал cp1251 для mysql, помогло, но не факт, что проблема была в этом!

Перед установкой прописал:

php_flag register_globals Off



# For servers that support output compression, you should pick up a bit of
# speed by un-commenting the following lines.

php_flag zlib.output_compression On
php_value zlib.output_compression_level 5



# The following directives stop screen flicker in IE on CSS rollovers. If
# needed, un-comment the following rules. When they're in place, you may have
# to do a force-refresh in order to see changes in your designs.

ExpiresActive On
ExpiresByType image/gif A2592000
ExpiresByType image/jpeg A2592000
ExpiresByType image/png A2592000
BrowserMatch "MSIE" brokenvary=1
BrowserMatch "Mozilla/4.[0-9]{2}" brokenvary=1
BrowserMatch "Opera" !brokenvary
SetEnvIf brokenvary 1 force-no-vary

-----------------------
Не рабочий восклицательный знак распростронялся не только на сниппеты, но и на все теги системы cms.]]>
flashrus Feb 28, 2013, 05:37 AM https://forums.modx.com/thread/82727/#dis-post-456913
<![CDATA[Re: Не работает восклицательный знак в тегах]]> https://forums.modx.com/thread/82727/#dis-post-456902
С таким как-то не доводилось сталкиваться. Возможно стоит явно указать, что это сниппет, добавив ? после имени: [[!snippetName?]]]]>
Alroniks Feb 28, 2013, 03:44 AM https://forums.modx.com/thread/82727/#dis-post-456902
<![CDATA[Re: Не работает восклицательный знак в тегах]]> https://forums.modx.com/thread/82727/#dis-post-456890 flashrus Feb 28, 2013, 02:05 AM https://forums.modx.com/thread/82727/#dis-post-456890 <![CDATA[Не работает восклицательный знак в тегах]]> https://forums.modx.com/thread/82727/#dis-post-456530
Пытаюсь запустить сниппет без кеша. Пишу [[!snippetName]] в шаблоне или конкретной странице (сниппет создан), итог: в место результата сниппета вываливается тег [[!snippetName]]. Кто сталкивался с проблемой?

P.S. Без восклицательного знака все работает.
P.S. Такой же баг распространяется на все виды тегов, не только сниппетов.]]>
flashrus Feb 25, 2013, 09:42 AM https://forums.modx.com/thread/82727/#dis-post-456530