<![CDATA[ [lang] Japanese Language Pack for 0.9.5 - MODX Community Forums]]> https://forums.modx.com/thread/?thread=56394 <![CDATA[Re: [lang] Japanese Language Pack for 0.9.5]]> https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5?page=2#dis-post-330929 php.iniを変えてあげれば可能ですよ wink
(CPIではディレクトリ毎にphp.iniを設定できますので・・・)

参考
http://modxcms.com/forums/index.php/topic,2573.msg103955.html#msg103955

エイリアスに関しても(もしEUCで運用されているのであれば)
上記の流れで解決のヒントになるかも・・・です。]]>
altstack Jul 28, 2007, 06:25 AM https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5?page=2#dis-post-330929
<![CDATA[Re: CPI&#12469;&#12540;&#12496;&#12395;&#12362;&#12369;&#12427;MODx&#12398;&#20351;&#29992;&#12395;&#12388;&#12356;&#12390;&#36074;&#21839;&#65306;&#25991;&#23383;&#12467;&#12540;&#12489;&#12398;&#21839;&#38988;]]> https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5?page=2#dis-post-330928
Quote from: Konomachi at Jul 28, 2007, 06:44 AM

スタイルシートとしてドキュメントを作成して保存する

css としてドキュメント生成したのですね、フムフム....
ということは admin で作業してますね。


Quote from: Konomachi at Jul 28, 2007, 06:44 AM

① "ドキュメントエイリアス"の部分が保存されない、

? これは結果でしかありません。

んんん、他の情報がないと解決の糸口が掴めない。
環境も分からないし、何かメッセージが出てないのでしょうか?


Quote from: Konomachi at Jul 28, 2007, 06:44 AM

② 保存の際に、エラーメッセージが出力される。

どんなメッセージなんでしょうね。


面倒くさいとは思いますが、いろいろな情報を提示してもらえると、素早く解
決方法が分かりますよ。医者の問診と同じです。

何を提示していいのか分からない時は、結果ではなく、modx が応えたメッセー
ジを出すのが一番いいですね。つまり ② のメッセージのことです。それで大
体見当が付きます。

他の cms もそうですが、modx も親切な方が一杯いらっしゃるので、良い質問
をされると良い回答が得られます。

じゃ、がんばってください。

p.s.
--
①,②などの特殊な文字は控えた方がいいです。この掲示板、文字コードが
ISO-8859-1 となっているので、ブラウザの努力で Windows では正常に見えま
すが、mac や unix 環境では文字化けしてるんじゃないですかね。

これもまた utf-8 だったら問題ないのですが。]]>
custar Jul 28, 2007, 05:36 AM https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5?page=2#dis-post-330928
<![CDATA[Re: [lang] Japanese Language Pack for 0.9.5]]> https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5?page=2#dis-post-330927
TinyMCE を使ってないので詳細は追ってませんが、下記メッセージを読むと、

Quote from: shinoiwa at Jul 04, 2007, 11:00 AM

Warning: getTinyMCESettings(/usr/home/****/modx/assets/plugins/tinymce2111/lang/japanese-euc.inc.php) [function.getTinyMCESettings]: failed to open stream: No such file or directory in /usr/home/****/modx/assets/plugins/tinymce2111/tinymce.functions.php on line 6

ということで、本当に assets/plugins/tinymce2111/lang/japanese-euc.inc.php
がないのが原因じゃないですか。utf8 版はあるので。

euc を使うのがまだまだ一般的なのでしょうか? しなくてもいい苦労が続くのに。]]>
custar Jul 28, 2007, 05:13 AM https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5?page=2#dis-post-330927
<![CDATA[Re: [lang] Japanese Language Pack for 0.9.5]]> https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5?page=2#dis-post-330926
ついででナニですが、翻訳をお手伝いいただける方がいらっしゃると助かります。
(作業内容は具体的にいくつかあります)]]>
yama Jul 28, 2007, 02:24 AM https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5?page=2#dis-post-330926
<![CDATA[Re: [lang] Japanese Language Pack for 0.9.5]]> https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5#dis-post-330925 まだ作ってなかったと思います。急いで用意しますので、しばらくお待ちください。]]> yama Jul 28, 2007, 02:00 AM https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5#dis-post-330925 <![CDATA[CPI&#12469;&#12540;&#12496;&#12395;&#12362;&#12369;&#12427;MODx&#12398;&#20351;&#29992;&#12395;&#12388;&#12356;&#12390;&#36074;&#21839;&#65306;&#25991;&#23383;&#12467;&#12540;&#12489;&#12398;&#21839;&#38988;]]> https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5#dis-post-330924
私もCPI(Servision)を利用しているのでが、shinoiwaさんと同様の現象が起こっています。
さらに、スタイルシートとしてドキュメントを作成して保存するときに、
①"ドキュメントエイリアス"の部分が保存されない、
②保存の際に、エラーメッセージが出力される。
等の問題が起こっています。

WordPressのUTF-8のときもそうでしたが、
CPIは文字コードに関することで、トラブルが多く本当に困っています。

こちらでもいろいろと調べて見ますが、わかりましたら教えてください。
よろしくお願いします。]]>
Konomachi Jul 28, 2007, 01:44 AM https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5#dis-post-330924
<![CDATA[Re: [lang] Japanese Language Pack for 0.9.5]]> https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5#dis-post-330923 一見普通に動いていますし、文字化けもないのですが、
管理画面で「ツール→MODx設定」画面に移動すると、下記のようなエラーが出てしまいます。

TinyMCE - OnInterfaceSettingsRender
An error occurred while loading. Please see the event log for more information.

Warning: getTinyMCESettings(/usr/home/****/modx/assets/plugins/tinymce2111/lang/japanese-euc.inc.php) [function.getTinyMCESettings]: failed to open stream: No such file or directory in /usr/home/****/modx/assets/plugins/tinymce2111/tinymce.functions.php on line 6

Warning: getTinyMCESettings() [function.include]: Failed opening ’/usr/home/****/modx/assets/plugins/tinymce2111/lang/japanese-euc.inc.php’ for inclusion (include_path=’/usr/home/****/modx/manager/includes/’) in /usr/home/****/modx/assets/plugins/tinymce2111/tinymce.functions.php on line 6


エラーの下に「OK」ボタンがあるので、クリックすると
その後は何事もなかったかのように普通に操作できるのですが・・・。
たしかに、Japanese Language Pack for 0.9.5(EUC-JP)の中には
/assets/plugins/tinymce2111/tinymce.functions.php
に相当するものは入っていないので、エラーが出るのも当然といえば同然の気がします。

が、一体じゃあどこからファイルを持ってくればいいのか?がわかりません。
どなたかわかる方いらっしゃいましたら、教えていただけないでしょうか。
ちなみにサーバーはCPI(Servision)です。

※20:03追記: 
ちなみに本体のバージョンは0.9.6です・・・、ってそこがもしや根本的にマズいのでしょうか。。。
CPIでは、UTFエンコードだと日本語がことごとく文字化けしてしまうので
どうしてもEUC化するしかないのかと思ってトライしています。
ややこしくてすみませんですが、どうぞよろしくお願いします。]]>
shinoiwa Jul 04, 2007, 06:00 AM https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5#dis-post-330923
<![CDATA[Re: [lang] Japanese Language Pack for 0.9.5]]> https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5#dis-post-330922 私もその画面のソースをちょっと見てみましたが。。
ソース自体、違反うんぬんとか始めると泥沼^^;)になりそうなので、
そこは、見ないふりを。。^^;

これに関しては、
「<span class="comment" style="width:300px;">」を
「<span class="comment" style="width:300px;display:block;">」に書き換えるほうが
正しいです。(CSS的には正しいのか?spanをblockて。 Huh)
「親ドキュメント」の説明文が押し出してしまっている感じです。

もともと、spanはインライン要素で、widthを定義出来ないので、
そちらが誤りです。
<span class="comment" style="width:300px;display:block;"
これは出来ます。

XHTML 1.1で、tdにwidthを定義するのは違反(だと思った…)なので、それを
取って表示がうまくいくならば、その方がいいのかもしれません。
でも、全体を詳しく見ていないので、何とも言えないんですけども。。

とりあえず、気づいた事を。。]]>
MEGU Jan 17, 2007, 02:43 AM https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5#dis-post-330922
<![CDATA[Re: [lang] Japanese Language Pack for 0.9.5]]> https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5#dis-post-330921 出てきたので、気になって調べてみました。具体的には添付画像のとおり。



メントエイリ。アスリンク。みたいな。。

結論から言うと、当トピックで配布されているlangファイルを適用後にこの状態になります。
langファイルに問題があるわけではなく、むしろちゃんと翻訳されたlangファイルだったために
分かったIE独特のレンダリングのバグのように思います。Firefoxでは問題ありません。
一部の翻訳をわざと中途半端にして、たとえば「リンク属性」を「Link Attributes」に戻すと
「Attributes」の文字幅ぶんだけ広がります。
ソースを見ると、ちゃんとtd width=’100’ となっています。
気になる場合は「manager/actions/mutate_content.dynamic.php」の中の該当個所の
width=’100’を削除すると、とりあえずそれなりに分かりやすく表示されるようになります。

※22時37分追記。
「<span class="comment" style="width:300px;">」を
「<span class="comment" style="width:300px;display:block;">」に書き換えるほうが
正しいです。(CSS的には正しいのか?spanをblockて。 huh)
「親ドキュメント」の説明文が押し出してしまっている感じです。]]>
yama Jan 16, 2007, 07:20 AM https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5#dis-post-330921
<![CDATA[Re: [lang] Japanese Language Pack for 0.9.5]]> https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5#dis-post-330920 yama Dec 08, 2006, 10:21 PM https://forums.modx.com/thread/56394/lang-japanese-language-pack-for-0-9-5#dis-post-330920