<![CDATA[ imagecreate function failing -->SOLVED - MODX Community Forums]]> https://forums.modx.com/thread/?thread=50745 <![CDATA[Re: imagecreate function failing --&gt;SOLVED]]> https://forums.modx.com/thread/50745/imagecreate-function-failing----solved#dis-post-297286 goldsky Aug 19, 2011, 05:57 AM https://forums.modx.com/thread/50745/imagecreate-function-failing----solved#dis-post-297286 <![CDATA[Re: imagecreate function failing - SOLVED]]> https://forums.modx.com/thread/50745/imagecreate-function-failing----solved#dis-post-297285 Goldsky you are the Man! Most sincere and humble thanks. For everyone else, I used the wrong thumbnail dimensions of 1px by 1px by accident and that was what was killing that function and creating the parse error. I also had parameters in snippet call that don’t correspond to snippet parameters.

The real problem was the 1 x 1 dimensions.


-Noah]]>
noahlearner Aug 18, 2011, 07:13 PM https://forums.modx.com/thread/50745/imagecreate-function-failing----solved#dis-post-297285
<![CDATA[Re: imagecreate function failing]]> https://forums.modx.com/thread/50745/imagecreate-function-failing----solved#dis-post-297284 Quote from: noahlearner at Aug 17, 2011, 05:41 PM

100 x 100 in the module options and the snippet options of the config call and the actual snippet call has a &h=`55` w=`55`

-Noah
This is strange.
Really.
I’ve tested on my localhost to deal with 14 MB picture without resizing, so it stayed as 14 MB.
I could still call it on the front end.
If you don’t mind, would you give me the cpanel and manager access?
Leave it on skype.

Thx ahead.]]>
goldsky Aug 18, 2011, 05:55 PM https://forums.modx.com/thread/50745/imagecreate-function-failing----solved#dis-post-297284
<![CDATA[Re: imagecreate function failing]]> https://forums.modx.com/thread/50745/imagecreate-function-failing----solved#dis-post-297283
-Noah]]>
noahlearner Aug 17, 2011, 12:41 PM https://forums.modx.com/thread/50745/imagecreate-function-failing----solved#dis-post-297283
<![CDATA[Re: imagecreate function failing]]> https://forums.modx.com/thread/50745/imagecreate-function-failing----solved#dis-post-297282 goldsky Aug 17, 2011, 12:07 PM https://forums.modx.com/thread/50745/imagecreate-function-failing----solved#dis-post-297282 <![CDATA[imagecreate function failing --&gt;SOLVED]]> https://forums.modx.com/thread/50745/imagecreate-function-failing----solved#dis-post-297281
SO I’ve uploaded the gallery images with you last night.

Client goes to upload images in same directory. I deleted images and reuploaded gallery, then when I go to check it out in the front end I get this as a warning
MODx encountered the following error while attempting to parse the requested resource:
« PHP Parse Error »
 
PHP error debug
  Error:	imagecreatetruecolor() [function.imagecreatetruecolor]: Invalid image dimensions	 
  Error type/ Nr.:	Warning - 2	 
  File:	/home/un/public_html/assets/modules/easy2/includes/models/e2g.public.thumbnail.class.php	 
  Line:	107	 
  Line 107 source:	 $temp = imagecreatetruecolor($tmp_w, $tmp_h);	 
 
Parser timing
  MySQL:	0.0082 s	(73 Requests)
  PHP:	0.9210 s	 
  Total:	0.9292 s


You can see the site at http://www.uniquenantucket.com/test.html

I don’t get it. When we looked at it last night, it worked. The images are all 640 x 427 or 640 x 480 px with filesizes ranging from 19kb to 81 kb.

I am flabbergasted.

-Noah]]>
noahlearner Aug 16, 2011, 11:13 PM https://forums.modx.com/thread/50745/imagecreate-function-failing----solved#dis-post-297281