<![CDATA[ [solved] Webpage has expired issue - MODX Community Forums]]> https://forums.modx.com/thread/?thread=48212 <![CDATA[Re: [solved] Webpage has expired issue]]> https://forums.modx.com/thread/48212/solved-webpage-has-expired-issue#dis-post-278930
The same error was reported by one of my users today. Strange that the site has been live for 2 years, but it hasn’t been reported before. No changes to MODx that would affect this, but maybe something PHP/Apache was changed on the server?

I put the code into a MODx snippet, so it only sets the Cache-Control header for the search page.
]]>
twz-17 May 24, 2011, 01:48 AM https://forums.modx.com/thread/48212/solved-webpage-has-expired-issue#dis-post-278930
<![CDATA[Re: [solved] Webpage has expired issue]]> https://forums.modx.com/thread/48212/solved-webpage-has-expired-issue#dis-post-278929
Fixed my issue.

<?php
header( ’Cache-Control: private, max-age=10800, pre-check=10800’ );
?>
]]>
nods_dorf Apr 01, 2010, 06:10 PM https://forums.modx.com/thread/48212/solved-webpage-has-expired-issue#dis-post-278929
<![CDATA[Re: [solved] Webpage has expired issue]]> https://forums.modx.com/thread/48212/solved-webpage-has-expired-issue#dis-post-278928 pgudge Feb 04, 2010, 11:11 AM https://forums.modx.com/thread/48212/solved-webpage-has-expired-issue#dis-post-278928 <![CDATA[ [solved] Webpage has expired issue]]> https://forums.modx.com/thread/48212/solved-webpage-has-expired-issue#dis-post-278927
I added a snippet to the top of the Template for the search results which adds this:

<?
header( ’Cache-Control: private, max-age=10800, pre-check=10800’ );
?>

Seems to work for me.
]]>
inga_thorn Nov 26, 2009, 06:38 AM https://forums.modx.com/thread/48212/solved-webpage-has-expired-issue#dis-post-278927
<![CDATA[ [solved] Webpage has expired issue]]> https://forums.modx.com/thread/48212/solved-webpage-has-expired-issue#dis-post-278926

Webpage has expired

Most likely cause: The local copy of this webpage is out of date, and the website requires that you download it again.
What you can try: Click on the Refresh button on the toolbar to reload the page. After refreshing, you might need to navigate to the specific webpage again, or re-enter information.


Does anyone know how can I avoid this?

]]>
inga_thorn Nov 24, 2009, 07:30 AM https://forums.modx.com/thread/48212/solved-webpage-has-expired-issue#dis-post-278926