<![CDATA[ Support/Comments for SPForm - MODX Community Forums]]> https://forums.modx.com/thread/?thread=46444 <![CDATA[Re: Support/Comments for SPForm]]> https://forums.modx.com/thread/46444/support-comments-for-spform?page=23#dis-post-552014
Does it work without &useHiddenField?

Usually SMTP is more reliable than phpmail.

You should only use the last two referers in your list: www.xxxxx.tld,xxxxx.tld
]]>
BobRay Jun 23, 2017, 11:14 PM https://forums.modx.com/thread/46444/support-comments-for-spform?page=23#dis-post-552014
<![CDATA[Re: Support/Comments for SPForm]]> https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-551994 http://www.xxxxx.tld/yyyyy.html)".

Your sollution was:
Check the &formProcAllowedReferers property of the snippet tag. Make sure it includes your server (yoursite.com,www.yoursite.com).
Also, check the emailsender System Setting and make sure it's an address at your own server.

Your solution did not work, the same error occur. I disabled SMTP email. The mails are sent from the same server with phpmail.
i tried to change the standard Configuration of the Snippet. Also added the option in the chunk. Nothing is working.

[[!SPForm? &useHiddenField=`1` &formProcAllowedReferers=`http://www.xxxxx.tld,http://xxxxx.tld,http://www.xxxxx.tld/yyyyy.html,www.xxxxx.tld,xxxxx.tld`]]
]]>
onsite.org Jun 23, 2017, 09:57 AM https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-551994
<![CDATA[Re: Support/Comments for SPForm]]> https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-547246 ]]> BobRay Dec 12, 2016, 11:11 PM https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-547246 <![CDATA[Re: Support/Comments for SPForm]]> https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-547227 jonahnaylor Dec 12, 2016, 03:27 PM https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-547227 <![CDATA[Re: Support/Comments for SPForm]]> https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-547164
When a user comes in on a www URL and gets transferred to a non-www URL (or vice versa), the session data is lost.

Make sure you uncomment one (but not both) of the sections in the root .htaccess file that forces www or non-www addresses.]]>
BobRay Dec 10, 2016, 07:34 PM https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-547164
<![CDATA[Re: Support/Comments for SPForm]]> https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-547157
I have the emailsender set in Settings. The correct www. and non-www domain formProcAllowedReferers (I even tried adding http:// entries in there too but took them out again when it didn't seem to help).

I'm running Revo 2.5.1 with spform 3.3.0-pl.

I don't have 'requireVerify' enabled on spform so there is no captcha. But I do have captcha enabled in System settings for manager logins.

I wonder if you could please help me to get the form working. What is odd is that it sometimes works on some browsers or phones and doesn't on others when trying combinations of different www. or not addresses. Also the form is on the homepage as well as other pages if that makes any difference? But the thank you page is always the same resource.

Thanks again for any help. smiley]]>
jonahnaylor Dec 10, 2016, 10:57 AM https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-547157
<![CDATA[Re: Support/Comments for SPForm]]> https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-544493 Quote from: terrybarth at Aug 24, 2016, 02:44 PM
Thank Bob
I assume this would be over written with any upgrade of this extra?

Actually, I don't think so. If it works, I'll probably build it into the next release.]]>
BobRay Aug 26, 2016, 04:13 AM https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-544493
<![CDATA[Re: Support/Comments for SPForm]]> https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-544458
I'll run it past my client. It's their busy season so they may want to wait before trying this. They have a work around in place for now.

I assume this would be over written with any upgrade of this extra?]]>
terrybarth Aug 24, 2016, 02:44 PM https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-544458
<![CDATA[Re: Support/Comments for SPForm]]> https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-544439

General Inquiries:info@domain.org, name@gmail.com||Administration:admin@domain.org, name@msn.com||Press & Media Inquiries: name@aol.com, name@msn.com


If you feel like living dangerously, try changing line 158 of the spformproc.class.php file from this:

$recipientArray = explode(',',$recipientArray);



to this:

$recipientArray = explode('||',$recipientArray);



Then change line 312 of the nearby spform.class.php file from this:

 $this->spfconfig['recipientArray'] = explode(',',$ra);


to this:

$this->spfconfig['recipientArray'] = explode('||',$ra);



Then change the format of the recipientArray property as described at the beginning of this post.

Be prepared to revert all the changes if it doesn't work. wink]]>
BobRay Aug 24, 2016, 03:25 AM https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-544439
<![CDATA[Re: Support/Comments for SPForm]]> https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-544436
When I do this in the contacts.cfg.php, I get a "invalid recipient"

Please choose a recipient: Please choose a recipient:
General Inquiries: General Inquiries: info@domain.org, name@gmail.com
Administration: Administration: admin@domain.org, name@msn.com
Press & Media Inquiries: Press & Media Inquiries: name@aol.com, name@msn.com

The form is working with only one address for each choice.

# $Revision: 106 $
# Version: 1.0.3]]>
terrybarth Aug 23, 2016, 09:38 PM https://forums.modx.com/thread/46444/support-comments-for-spform?page=22#dis-post-544436