<![CDATA[ [SOLVED!] The Mysterious Missing TinyMCE and the Stow-Away Settings - MODX Community Forums]]> https://forums.modx.com/thread/?thread=45839 <![CDATA[Re: [SOLVED!] The Mysterious Missing TinyMCE and the Stow-Away Settings]]> https://forums.modx.com/thread/45839/solved-the-mysterious-missing-tinymce-and-the-stow-away-settings#dis-post-265394 ]]> TXRX Apr 24, 2007, 09:43 AM https://forums.modx.com/thread/45839/solved-the-mysterious-missing-tinymce-and-the-stow-away-settings#dis-post-265394 <![CDATA[ [SOLVED!] The Mysterious Missing TinyMCE and the Stow-Away Settings]]> https://forums.modx.com/thread/45839/solved-the-mysterious-missing-tinymce-and-the-stow-away-settings#dis-post-265393 http://modxcms.com/forums/index.php/topic,5403.msg87763.html#msg87763

...ok, so maybe it didn’t begin there, but that post sums up pretty clearly the problem I was experiencing. Very frustrating.

I thought it was a corrupt TinyMCE file or missing dependent. Reinstalled: Nothing.
I thought it was a corrupt SVN issue. Upgraded to 096 RC2, then RC3: Nope.
I thought it was a damaged plugin or missing System Event. All checked out: Zilch. Zip.

Finally, I stumbled upon a post indicating that--as of 096 RC2/RC3--TinyMCE Themes were not updating in the Manager Configuration. So, I decided I’d try changing themes. Sure enough, the theme change does not register, nor did it help with my mysterious, missing editor. sad

However, the post also referenced the modx_system_settings table--and user premissions--and I eventually found modx_user_settings table containing setting_name: tinymce_editor_theme

To my surprise, I found the setting_value of: full

That’s odd. When looking into the list of available themes, the only values I saw were:
simple
advanced
editor
custom

No "full" on that list...Hmmm...
Keep in mind my error stemmed from a 095 development to production migration with 096 RCx upgrades. That said, it seems plausible that a third-party-based setting--likely now a legacy reference with the release of TinyMCE 2.1.0--could have snuck through (unknown to the updater) wreaking havoc on my client’s editing abilities.

I manually updated the database and changed the value from full to custom and my "mysterious problem" mysteriously went away! cool (Finally.)

In short, if you ever experience an issue like here: http://modxcms.com/forums/index.php/topic,5403.msg87763.html#msg87763 remember this thread!]]>
pixelchutes Apr 24, 2007, 01:05 AM https://forums.modx.com/thread/45839/solved-the-mysterious-missing-tinymce-and-the-stow-away-settings#dis-post-265393