<![CDATA[ yams ditto and phx - MODX Community Forums]]> https://forums.modx.com/thread/?thread=45634 <![CDATA[Re: yams ditto and phx]]> https://forums.modx.com/thread/45634/yams-ditto-and-phx#dis-post-263969
sorry, often afk those days...

in order to be complete for yams to know everything it needs, your ditto call must also contain &id=`(yams_id)` &language=`(yams_mname)`, that’s to say
[!Ditto? &id=`(yams_id)` &language=`(yams_mname)` &extenders=`@FILE assets/modules/yams/yams.extender.inc.php` ../..

have you tried with that kind of complete ditto/yams call ?

Hace swing]]>
virtualbear Jul 27, 2011, 01:40 AM https://forums.modx.com/thread/45634/yams-ditto-and-phx#dis-post-263969
<![CDATA[Re: yams ditto and phx]]> https://forums.modx.com/thread/45634/yams-ditto-and-phx#dis-post-263968 when i add:
<img src="[+grote-afb_(yams_id)+]">

then in the source:
<img src="">

when i change it to:
<img src="[+grote-afb_en+]"> or <img src="[+grote-afb_nl+]">

then in the source its ok.


Changing my dittocall didnt help either,
[!Ditto?extenders=`@FILE assets/modules/yams/yams.extender.inc.php`


maybe some config of yams i dunno.
]]>
fourroses666 Jul 25, 2011, 03:26 AM https://forums.modx.com/thread/45634/yams-ditto-and-phx#dis-post-263968
<![CDATA[Re: yams ditto and phx]]> https://forums.modx.com/thread/45634/yams-ditto-and-phx#dis-post-263967
have you tried
<img src="[*phx:input=`[+grote-afb_(yams_id)+]`:phpthumb=`w=130&h=85&zc=C&q=85`*]">

don’t know what exactly you’re doing (i do not use phpthumb) but it may be a solution (actually, it’s one i use in different occasions smiley

Have swing]]>
virtualbear Jul 25, 2011, 02:57 AM https://forums.modx.com/thread/45634/yams-ditto-and-phx#dis-post-263967
<![CDATA[yams ditto and phx]]> https://forums.modx.com/thread/45634/yams-ditto-and-phx#dis-post-263966 1.) <img src="[*phx:input=`[+grote-afb_en+]`:phpthumb=`w=130&h=85&zc=C&q=85`*]">
or <img src="[*phx:input=`[+grote-afb_nl+]`:phpthumb=`w=130&h=85&zc=C&q=85`*]">

This doesn’t:
2.) <img src="[*phx:input=`[[YAMS? &get=`tv` &from=`grote-afb`]]`:phpthumb=`w=130&h=85&zc=C&q=85`*]">


I get an phpthumb error, if i look at the source, 1. is okee, 2. is not, because it grabs the wrong tv, it grabs the tv of the page where i am and not the "ditto" one:
1.) <img src="/image.php?src=assets/images/dummy.jpg&amp;w=130&amp;h=85&amp;zc=C&amp;q=85&amp;hash=d5b7291aa8bc0edea4d20eee88ff4676">
2.) <img src="/image.php?src=assets/images/agenda/agenda_b.jpg&amp;w=130&amp;h=85&amp;zc=C&amp;q=85&amp;hash=e1515fa7d60f267fa993f2b5913b1aa0">

My ditto call:
[!Ditto? &parents=`[*id*]` &total=`99` &showPublishedOnly=`1` &orderBy=`menuindex ASC` &noResults=`` &tpl=`overzicht-inhoud`!]
]]>
fourroses666 Jul 19, 2011, 03:05 AM https://forums.modx.com/thread/45634/yams-ditto-and-phx#dis-post-263966