<![CDATA[ Problem with Jot snippet and extended characters - MODX Community Forums]]> https://forums.modx.com/thread/?thread=43243 <![CDATA[Re: Problem with Jot snippet and extended characters]]> https://forums.modx.com/thread/43243/problem-with-jot-snippet-and-extended-characters#dis-post-249571 Work for version Jot 1.1.4
In file ’includes/jot.install.db.sql’ you need add "DEFAULT CHARSET=utf8" to every create table statement, and DROP TABLE `jot_content`, `jot_fields`, `jot_subscriptions`.
Or copy-paste this

CREATE TABLE IF NOT EXISTS `{PREFIX}jot_content` (
  `id` int(10) NOT NULL auto_increment,
  `title` varchar(255) default NULL,
  `tagid` varchar(50) default NULL,
  `published` int(1) NOT NULL default '0',
  `uparent` int(10) NOT NULL,
  `parent` int(10) NOT NULL default '0',
  `flags` varchar(25) default NULL,
  `secip` varchar(32) default NULL,
  `sechash` varchar(32) default NULL,
  `content` mediumtext,
  `mode` int(1) NOT NULL default '1',
  `createdby` int(10) NOT NULL default '0',
  `createdon` int(20) NOT NULL default '0',
  `editedby` int(10) NOT NULL default '0',
  `editedon` int(20) NOT NULL default '0',
  `deleted` int(1) NOT NULL default '0',
  `deletedon` int(20) NOT NULL default '0',
  `deletedby` int(10) NOT NULL default '0',
  `publishedon` int(20) NOT NULL default '0',
  `publishedby` int(10) NOT NULL default '0',
  PRIMARY KEY  (`id`),
  KEY `parent` (`parent`),
  KEY `secip` (`secip`),
  KEY `tagidx` (`tagid`),
  KEY `uparent` (`uparent`)
) TYPE=MyISAM DEFAULT CHARSET=utf8;


CREATE TABLE IF NOT EXISTS `{PREFIX}jot_subscriptions` (
  `id` mediumint(10) NOT NULL auto_increment,
  `uparent` mediumint(10) NOT NULL,
  `tagid` varchar(50) NOT NULL,
  `userid` mediumint(10) NOT NULL,
  PRIMARY KEY  (`id`),
  KEY `uparent` (`uparent`),
  KEY `tagid` (`tagid`),
  KEY `userid` (`userid`)
) TYPE=MyISAM DEFAULT CHARSET=utf8;


CREATE TABLE IF NOT EXISTS `{PREFIX}jot_fields` (
  `id` mediumint(10) NOT NULL,
  `label` varchar(50) NOT NULL,
  `content` text,
  KEY `id` (`id`),
  KEY `label` (`label`)
) TYPE=MyISAM DEFAULT CHARSET=utf8;


Or if you don`t want reinstall snippet Jot and lost you comments, you can change charset to UTF8 of `jot_content`, `jot_fields`, `jot_subscriptions` tables (and you would must decoding to UTF8 existing comments).]]>
bessangel May 07, 2010, 09:44 AM https://forums.modx.com/thread/43243/problem-with-jot-snippet-and-extended-characters#dis-post-249571
<![CDATA[Re: Problem with Jot snippet and extended characters]]> https://forums.modx.com/thread/43243/problem-with-jot-snippet-and-extended-characters#dis-post-249570 Quote from: ScreamerMM at Oct 16, 2009, 09:03 AM

<li>Påkrævede felter er markeret med: <b>*</b>.</li>


I got same problem with ä,ö. I tried use html entities, like &auml;(ä) but it didn’t work for me. I’m using UTF-8, but not sure about my db connection type.]]>
ikivela Mar 13, 2010, 06:23 AM https://forums.modx.com/thread/43243/problem-with-jot-snippet-and-extended-characters#dis-post-249570
<![CDATA[Re: Problem with Jot snippet and extended characters]]> https://forums.modx.com/thread/43243/problem-with-jot-snippet-and-extended-characters#dis-post-249569
Trying to change:

<li>Required fields are marked with <b>*</b>.</li>


This works:

<li>Påkrævede felter er markeret med: <b>*</b>.</li>


This does NOT work:

<li>Påkrævede felter er markeret med: <b>*</b>.</li>


It takes forever if i have to change every piece of text like this, because øåæ is quite common in danish.
I am using UTF-8 from within MODx!]]>
ScreamerMM Oct 16, 2009, 04:03 AM https://forums.modx.com/thread/43243/problem-with-jot-snippet-and-extended-characters#dis-post-249569
<![CDATA[Re: Problem with Jot snippet and extended characters]]> https://forums.modx.com/thread/43243/problem-with-jot-snippet-and-extended-characters#dis-post-249568 Alik Jul 04, 2009, 08:31 PM https://forums.modx.com/thread/43243/problem-with-jot-snippet-and-extended-characters#dis-post-249568 <![CDATA[Re: Problem with Jot snippet and extended characters]]> https://forums.modx.com/thread/43243/problem-with-jot-snippet-and-extended-characters#dis-post-249567
Martin]]>
FuryDE Jun 16, 2009, 11:01 AM https://forums.modx.com/thread/43243/problem-with-jot-snippet-and-extended-characters#dis-post-249567
<![CDATA[Problem with Jot snippet and extended characters]]> https://forums.modx.com/thread/43243/problem-with-jot-snippet-and-extended-characters#dis-post-249566
I’m just testing the Jot snippet, and I wanted to change the &validate parameter. But suddenly it didn’t work anymore and I found out that the "Umlaut" (German characters - ä, ö and ü) has bugged modx. However, I’ve changed it from ü to ue and then it worked well. But nevertheless it would be cool if the characters would work.]]>
GeorgM Dec 27, 2008, 05:07 PM https://forums.modx.com/thread/43243/problem-with-jot-snippet-and-extended-characters#dis-post-249566