<![CDATA[ Support/Comments for [Plugin] EditArea 0.5.1-GA - MODX Community Forums]]> https://forums.modx.com/thread/?thread=38531 <![CDATA[Re: Support/Comments for [Plugin] EditArea 0.5.1-GA]]> https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220181 Haha I’d forgotten about the per Manager User settings laugh]]> bunk58 Mar 18, 2010, 03:45 AM https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220181 <![CDATA[Re: Support/Comments for [Plugin] EditArea 0.5.1-GA]]> https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220180 Quote from: bunk58 at Aug 13, 2009, 06:36 PM

Nice job, particularly with the installer grin
What about adding the option to set all the content to RTE Off?
I use a snippet at the moment to change all the demo content to RTE Off, then reverse it when the site is handed over.
$rs= $modx->db->query('UPDATE `modx_site_content` SET `richtext`=0');


@bunk58,

1. Go to "MODx Manager > Security > Manager Users"
2. Click on your manager user
3. On the "User" tab (next to ’General’), scroll down till you find Editor to use
4. Change the default option to "None"

Voila! You now have user-specific, EditArea as the default text editor! What is nice about this solution is that it still allows you to change from "None" to "TinyMCE" should you ever need to load the RTE while editing a Resource.

Best of luck!]]>
pixelchutes Mar 17, 2010, 10:16 PM https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220180
<![CDATA[ [Plugin] EditArea 0.5.2-GA Released!]]> https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220179
Loooong overdue, but here is a much-needed updated for the EditArea plugin...Best of all, it fixes many of the syntax highlighting issues, specifically in FireFox. EditArea Plugin is usable again! cool ( See below for complete EA changelog)

Download attachment from this post until updated package is approved in the Add-Ons section.

Updates to Plugin / Installer:
- EA Save Button + ’CTRL + S’ hotkey now working in Internet Explorer again (Updated EditArea MODx JavaScript plugin)
- Improved language support (added missing .JS files causing bloated error logs)
- Added Russian language support to plugin (thx MarSoft)
- Removed unnecessary checks during Install process (e.g. no longer requires config.inc.php to be writable, etc... thx MarSoft)
- Added missing "Text" syntax highlighting definition files (thx JUSI)
- Enabled the Syntax Selection list plugin by default (thx JUSI)

...now you can change your syntax highlighting definition on-the-fly! Support for Text, JavaScript, CSS, XML/HTML, and PHP within MODx! (NOTE: syntax default is driven by content-type. For chunks with CSS or JavaScript, they unfortunately will default to HTML, although it’s easy to change and the bulk of chunks is generally HTML anyway)

Quote from: "EA

**** v 0.8.2 ****
- Change back to remove the speed optimization for highlight process introduced in 0.8.1 that has too much bugs
- Syntax name are no more stored in language files but in syntax files. Those display names will be used only if the compressor tools is used, otherwise syntax code is displayed
- Activate word-wrap feature for opera > 9.6
- Bug fix: Selection wasn’t correctly remembered between file tabs
- Bug fix: [2886499] Page up and page Down action are no more executed if Alt touch is pressed
- Bug fix: [2887118] UTF-8 encoded URLs return wrong base URL
- Bug fix: [2851936] Unresolved reference to isIE in elements_functions.js
- Bug fix: [2886836] get_IE_selection bug when closed...
- bug fix: JavaScript error when switching to fullscreen (https://sourceforge.net/projects/editarea/forums/forum/556921/topic/3388824)
- Bug fix (but not applicable due to change back) : [2854519, 2854642, 2792217, 2834579 ] Desynchronization occurred with <, > and & characters


]]>
pixelchutes Mar 17, 2010, 10:00 PM https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220179
<![CDATA[Re: Support/Comments for [Plugin] EditArea 0.5.1-GA]]> https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220178 http://vimeo.com/7405114

Zen Coding is ridiculous + so awesome laugh

*I tried coda again two days ago. i wanna love it, ftp thing is cool,.. but just...can’t. textmate is too powerful!]]>
featherodd Feb 27, 2010, 02:20 PM https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220178
<![CDATA[Re: Support/Comments for [Plugin] EditArea 0.5.1-GA]]> https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220177 ]]> bunk58 Feb 27, 2010, 01:53 PM https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220177 <![CDATA[Re: Support/Comments for [Plugin] EditArea 0.5.1-GA]]> https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220176
still showed the text [zencoding] in the toolbar (unlike the zen coding demo online), but all the hotkeys worked this time. F’in awesome =. html:5>#wrapper>div#page.container.grid-overlay>div#header+div#sidebar+div#content+div#footer

God I love MODx + cool shiz by other people!

Thanks for the heads up laugh]]>
featherodd Feb 27, 2010, 01:38 PM https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220176
<![CDATA[Re: Support/Comments for [Plugin] EditArea 0.5.1-GA]]> https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220175 featherodd Feb 27, 2010, 05:01 AM https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=3#dis-post-220175 <![CDATA[Re: Support/Comments for [Plugin] EditArea 0.5.1-GA]]> https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=2#dis-post-220174 Active Plugins -> modx,zencoding
That worked for me, after uploading the zencoding folder to :
assets/plugins/edit_area/core/edit_area/plugins/]]>
bunk58 Feb 27, 2010, 04:38 AM https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=2#dis-post-220174
<![CDATA[Re: Support/Comments for [Plugin] EditArea 0.5.1-GA]]> https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=2#dis-post-220173 http://zen-coding.ru/demo/)?

No matter what I try, I just get the text [zencoding] jammed into my EditArea toolbar when I try to load the plugin.]]>
featherodd Feb 27, 2010, 03:05 AM https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=2#dis-post-220173
<![CDATA[Re: Support/Comments for [Plugin] EditArea 0.5.1-GA]]> https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=2#dis-post-220172 http://code.google.com/p/modxeditarea/]]> mac2000 Jan 29, 2010, 07:59 AM https://forums.modx.com/thread/38531/support-comments-for-plugin-editarea-0-5-1-ga?page=2#dis-post-220172