<![CDATA[ Font page suddenly complaining about missing /includes/defines.php - MODX Community Forums]]> https://forums.modx.com/thread/?thread=36399 <![CDATA[Re: Font page suddenly complaining about missing /includes/defines.php]]> https://forums.modx.com/thread/36399/font-page-suddenly-complaining-about-missing-includes-defines-php#dis-post-205312 /mounted-storage/home43a/sub006/sc32167-DHIS/www/index.php(1) : eval()’d code(3) : eval()’d code on line 21 and see what its trying to do.
]]>
shamblett Dec 10, 2008, 11:55 PM https://forums.modx.com/thread/36399/font-page-suddenly-complaining-about-missing-includes-defines-php#dis-post-205312
<![CDATA[Font page suddenly complaining about missing /includes/defines.php]]> https://forums.modx.com/thread/36399/font-page-suddenly-complaining-about-missing-includes-defines-php#dis-post-205311 http://www.vicphysics.org/ :

Warning: require_once() [function.require-once]: Unable to access /mounted-storage/home43a/sub006/sc32167-DHIS/www/includes/defines.php in /mounted-storage/home43a/sub006/sc32167-DHIS/www/index.php(1) : eval()'d code(3) : eval()'d code on line 21

Warning: require_once(/mounted-storage/home43a/sub006/sc32167-DHIS/www/includes/defines.php) [function.require-once]: failed to open stream: No such file or directory in /mounted-storage/home43a/sub006/sc32167-DHIS/www/index.php(1) : eval()'d code(3) : eval()'d code on line 21

Fatal error: require_once() [function.require]: Failed opening required '/mounted-storage/home43a/sub006/sc32167-DHIS/www/includes/defines.php' (include_path='.:/usr/share/php5/') in /mounted-storage/home43a/sub006/sc32167-DHIS/www/index.php(1) : eval()'d code(3) : eval()'d code on line 21


No changes have been made to the site that could account for this error. Subpages on the site are working fine, eg: http://www.vicphysics.org/manager http://www.vicphysics.org/forums

I have contacted the host and they say I need to restore the /includes dorectory (which does not appear on the server currently) from backup. However looking at the backup and the original install, there doesn’t ever seem to have been an /includes directory under /www

Does anyone have any suggestions as to what’s going on here?

Thanks in advance!]]>
neilcreek Dec 10, 2008, 10:15 PM https://forums.modx.com/thread/36399/font-page-suddenly-complaining-about-missing-includes-defines-php#dis-post-205311