<![CDATA[ Having problems with package installations - MODX Community Forums]]> https://forums.modx.com/thread/?thread=31247 <![CDATA[Re: Having problems with package installations]]> https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-562260 I changed the domainname and forget to change this setting. It will crash all package management...]]> voklee Oct 22, 2018, 12:31 PM https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-562260 <![CDATA[Re: Having problems with package installations]]> https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-169011 shamblett Jun 01, 2011, 09:23 AM https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-169011 <![CDATA[Re: Having problems with package installations]]> https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-169010
Target directory is either not a directory or writable: home/myWebsite/public_html/core/packages/
Successfully grabbed package. Now attempting to remove transport zip...
Could not transfer package formit-1.5.4-pl.transport.zip to home/myWebsite/public_html/core/packages/.
Grabbing package to remove...
Attempting to remove extracted transport directory...
Successfully removed transport zip.
Package successfully removed.
Removed modTransportPackage instance with primary key formit-1.5.4-pl
Successfully removed extracted transport directory.
Could not load transport package.]]>
9thwave Jun 01, 2011, 07:33 AM https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-169010
<![CDATA[Re: Having problems with package installations]]> https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-169009 shamblett Jun 01, 2011, 07:11 AM https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-169009 <![CDATA[Re: Having problems with package installations]]> https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-169008
Thanks for your reply.
The core and packages directories are both set to 755.
Packages were actually installed when the site was first set up but not now i’ve come back to it after a couple of months!

Could there be anything else i could try?
]]>
9thwave Jun 01, 2011, 06:59 AM https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-169008
<![CDATA[Re: Having problems with package installations]]> https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-169007 Target directory is either not a directory or writable: home/myWebsites/public_html/core/packages/ Set the package directory to writeable as well as the core directory.]]> shamblett Jun 01, 2011, 06:18 AM https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-169007 <![CDATA[Having problems with package installations]]> https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-169006
I’m having some issues with installing and updating any packages.
I’m using 2.0.8-pl on Linux server. I have other Revo sites running on this server without any problems. The only difference in this instance is the site is using a temporary url which is an ip.
I have checked in MySQL the path in the workspace_ table and it seems to be ok and the ’core’ directory is writable.
When i try to update a package i get the ’saving’ window and then ’package_download_err’ window.
When i try to install a package (in this instance Wayfinder)i get blank screen all the way to the final window which displays:

Could not install package with signature: wayfinder-2.3.0-rc2
Target directory is either not a directory or writable: home/myWebsites/public_html/core/packages/

Attempting to install package with signature: wayfinder-2.3.0-rc2
Could not transfer package wayfinder-2.3.0-rc2.transport.zip to home/myWebsite/public_html/core/packages/.
Package found...now preparing to install.


When i try to download a package, in this instance the simpleSearch i get:
Could not download package at: http://modx.com/extras/download/?id=4ddfa008f245545fbc000044

Could anyone suggest what might be the problem?

Thanks for any help

J]]>
9thwave Jun 01, 2011, 05:54 AM https://forums.modx.com/thread/31247/having-problems-with-package-installations#dis-post-169006