<![CDATA[ modx.com registration form silently fails - MODX Community Forums]]> https://forums.modx.com/thread/?thread=24506 <![CDATA[Re: modx.com registration form silently fails]]> https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125006 ]]> markh Apr 28, 2011, 09:25 AM https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125006 <![CDATA[Re: modx.com registration form silently fails]]> https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125005
When I try to login using a false username I get discuss.user_err_nf - guess Shaun’s been working on the integration and the account can not be found in discuss? That’s definitely a bug.

I’m unable of seeing a HTTP 500 error though...



As said on Twitter yesterday - had no trouble registering an account (if anyone wants to delete it: the username is usertest) either..]]>
markh Apr 28, 2011, 08:07 AM https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125005
<![CDATA[Re: modx.com registration form silently fails]]> https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125004
Thanks for helping me on skype. It apparently does give an error message, but it was on a hidden div wink

I understand that you will post these three bugs in the bugtracker:
- Error messages on registration don’t appear after submitting form
- ’Username should be lowercase’ error seems useless, just do a case-insensitive check and store it as lowercase.
- Incorrect username/password gives HTTP 500]]>
Huppie Apr 28, 2011, 06:14 AM https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125004
<![CDATA[Re: modx.com registration form silently fails]]> https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125003
Is it possible we can chat on skype and I could figure out exactly whats happening in this specific case?

skype is: zaighamrana]]>
zaigham Apr 28, 2011, 05:36 AM https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125003
<![CDATA[modx.com registration form silently fails]]> https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125002
I’ve been told I have to report this on the forums as well, so here goes.

1) Your registration form SILENTLY fails when you register a new account. No error, no confirmation, no message that something is wrong in your backend, nothing. Did I tell you I think this is awful? First people tell me to stop venting on twitter and start submitting bugreports, then they tell me to go to the forum to tell you guys that I can’t file bugreports because the ’register an account’ form is broken, woohoo lucky me that registering an account on the forum works smiley

I had Jay Gilmore on skype yesterday, who told me it has been fixed, however I still get a silent fail every time I try to register.

2) If you enter an ’incorrect username / password’ today (after it has been ’fixed’) you don’t get a message that the user/pass is incorrect, you’ll get an HTTP 500 Internal Server Error.

So please:
1) Fix the 500 internal server error on incorrect username / password.
2) Fix any scenarios where your login form could silently fail. (You should NEVER silently fail, it’s by far the worst / most frustrating experience you can give a new user like me.)
3) Test if you can now properly register a new account (don’t just test that, test all scenarios and verify that you’ll get the proper response / error message and no silent failures).

Here’s what I tried:
- Register in Chrome 10
- Register in Chrome 11 (today)
- Register in Firefox 4
- Tried all of the above in ’Incognito mode’ so no cookies are used
- Tried clearing my flash cookies (because I’m not sure what these do in incognito mode)

Oh, and I’m on Windows 7.]]>
Huppie Apr 28, 2011, 04:51 AM https://forums.modx.com/thread/24506/modx-com-registration-form-silently-fails#dis-post-125002