<![CDATA[ action_err_ns - MODX Community Forums]]> https://forums.modx.com/thread/?thread=104796 <![CDATA[action_err_ns]]> https://forums.modx.com/thread/104796/action-err-ns#dis-post-563553 andrace Jan 14, 2019, 05:21 PM https://forums.modx.com/thread/104796/action-err-ns#dis-post-563553 <![CDATA[Re: action_err_ns]]> https://forums.modx.com/thread/104796/action-err-ns#dis-post-564200 Quote from: andrace at Jan 14, 2019, 05:21 PM
Hi all. Please advise what should I do. A couple days ago , my site changed to the https protocol, after that I receive this error action_err_ns. When I run synchronization of data, it proced multiple requests one after another, an amoun of requests is eqaul 600-620, and in one time it complete successfull, and other time may interrupted after any amount of requests. Cache cleared already multple times but didnt help. modx version 2.5.4

Hi,
There must be an .htaccess file higher up that's doing some odd rewriting.]]>
amelia Feb 22, 2019, 11:01 PM https://forums.modx.com/thread/104796/action-err-ns#dis-post-564200
<![CDATA[Re: action_err_ns]]> https://forums.modx.com/thread/104796/action-err-ns#dis-post-564058 Anyway I verified a js code, and within files all links is relative and not absolute

As Mark said, it's likely that some link or 'include' or 'require' in an extra, image, or template, has 'http' hard-coded somewhere. It fails when that code is hit.

Code that loads external libs like JQuery is a common culprit.

You can change the protocol from http:// to just // to fix it.


]]>
BobRay Feb 12, 2019, 07:27 PM https://forums.modx.com/thread/104796/action-err-ns#dis-post-564058
<![CDATA[Re: action_err_ns]]> https://forums.modx.com/thread/104796/action-err-ns#dis-post-564054 andrace Feb 12, 2019, 06:11 PM https://forums.modx.com/thread/104796/action-err-ns#dis-post-564054 <![CDATA[Re: action_err_ns]]> https://forums.modx.com/thread/104796/action-err-ns#dis-post-563566 Quote from: markh at Jan 14, 2019, 07:32 PM
action_err_ns means the action isn't set (ns = not set). What I suspect has happened is that (POST) requests to a connector is being sent to your HTTP URL, get redirect to HTTPS, and therefore drop their POST data (including the action).

That should be visible in the network tab, and would be fixed by updating where-ever that http url is coming from

Thanks for your advice, but I think that if it was be as you explained, requests not proceed at all whole time, but not time to time. Anyway I verifyed a js code, and within files all links is relative and not absolute]]>
andrace Jan 14, 2019, 07:58 PM https://forums.modx.com/thread/104796/action-err-ns#dis-post-563566
<![CDATA[Re: action_err_ns]]> https://forums.modx.com/thread/104796/action-err-ns#dis-post-563565 Quote from: BobRay at Jan 14, 2019, 06:58 PM
I'd suggest using the UpgradeMODX extra to upgrade your site to Version 2.6.0, then 2.6.5 immediately. There are serious security issues in your version and the upgrade might help with the problem.

Be sure the server_protocol System Setting is set to https. You may also need a rewrite rule in .htaccess to make sure all requests are forced to use https.

Also, in the program you're running, a hard-coded 'http' reference (like an image or JS source file) could cause the problem.

I'll try to upgrade. Thanks for your advise]]>
andrace Jan 14, 2019, 07:51 PM https://forums.modx.com/thread/104796/action-err-ns#dis-post-563565
<![CDATA[Re: action_err_ns]]> https://forums.modx.com/thread/104796/action-err-ns#dis-post-563560
That should be visible in the network tab, and would be fixed by updating where-ever that http url is coming from]]>
markh Jan 14, 2019, 07:32 PM https://forums.modx.com/thread/104796/action-err-ns#dis-post-563560
<![CDATA[Re: action_err_ns]]> https://forums.modx.com/thread/104796/action-err-ns#dis-post-563558
Be sure the server_protocol System Setting is set to https. You may also need a rewrite rule in .htaccess to make sure all requests are forced to use https.

Also, in the program you're running, a hard-coded 'http' reference (like an image or JS source file) could cause the problem.]]>
BobRay Jan 14, 2019, 06:58 PM https://forums.modx.com/thread/104796/action-err-ns#dis-post-563558