<![CDATA[ MODx broken? - MODX Community Forums]]> https://forums.modx.com/thread/?thread=104735 <![CDATA[MODx broken?]]> https://forums.modx.com/thread/104735/modx-broken?page=2#dis-post-563281 Hoi,

Voorheen stond MODx geïnstalleerd op onze site https://borderline-kasteel.nl
Ik kon er inloggen middels https://borderline-kasteel.nl/manager
Hier had ik een groen/witte achtergrond, waar ik de subpagina's zag en kon bewerken. (Add-on? is is dit het gebruikelijke MODx?)

Op de éen of andere manier, werkt https://borderline-kasteel.nl/manager niet meer.
De pagina blijft wit.

Nu durf ik het script MODx niet opnieuw te installeren om de volgende 2 redenen;
1. ik weet niet waar het vorige script geïnstalleerd stond
2. ik ben bang, dat de huidige opmaak van de site, volledig verloren gaat.

*Kanttekening;
De site is gebouwd door een vriendin van mij
Enkel via MODx kon ik redelijk overweg met aanpassingen van de site
Buiten dat om heb ik er vrij weinig verstand van, vandaar mijn noodkreet alhier.
[/DUTCH]

Hi,
Formerly was MODx installed on our site https://borderline-kasteel.nl
I could log in through https://borderline-kasteel.nl/manager
Here I had a green/white background, where I saw and could edit the subpages. (Add-on? is this the usual MODx?)

On the one way or another, https://borderline-kasteel.nl/manager no longer works.
The page remains white.
Now I dare reinstall the script, however, MODx may not be for the following 2 reasons;
1. I do not know where the previous script was installed
2. I am afraid, that the current layout of the site, completely lost.

* Side note; The site was built by a friend of mine
Just via MODx I could reasonably handle adjustments to the site outside that I have pretty little minds of, hence my cry for help here.
]]>
neo-81 Dec 16, 2018, 02:25 PM https://forums.modx.com/thread/104735/modx-broken?page=2#dis-post-563281
<![CDATA[Re: MODx broken?]]> https://forums.modx.com/thread/104735/modx-broken?page=2#dis-post-563972

Look in the MODX site directory in the core/config/config.inc.php file. You will see the name of the DB MODX is using for your site.

Also, FYI: https://bobsguides.com/modx-friendly-hosts.html.
]]>
BobRay Feb 05, 2019, 06:14 PM https://forums.modx.com/thread/104735/modx-broken?page=2#dis-post-563972
<![CDATA[Re: MODx broken? (Best Answer)]]> https://forums.modx.com/thread/104735/modx-broken?page=2#dis-post-563937 sophieschoice Feb 04, 2019, 10:18 AM https://forums.modx.com/thread/104735/modx-broken?page=2#dis-post-563937 <![CDATA[Re: MODx broken?]]> https://forums.modx.com/thread/104735/modx-broken#dis-post-563935 Quote from: BobRay at Feb 04, 2019, 08:42 AM
Quote from: BobRay at Feb 01, 2019, 11:49 PM

You could also follow the upgrade instructions here to upgrade: https://bobsguides.com/modx-upgrade-faq.html.

Do the upgrades in steps: 2.3.0, 2.4.0, 2.5.0, 2.6.0, 2.7.0.


if I try:


and go to:


then I see this:


i'm sp dumb on this shit sad]]>
neo-81 Feb 04, 2019, 10:09 AM https://forums.modx.com/thread/104735/modx-broken#dis-post-563935
<![CDATA[Re: MODx broken?]]> https://forums.modx.com/thread/104735/modx-broken#dis-post-563927 Quote from: BobRay at Feb 01, 2019, 11:49 PM

You could also follow the upgrade instructions here to upgrade: https://bobsguides.com/modx-upgrade-faq.html.

Do the upgrades in steps: 2.3.0, 2.4.0, 2.5.0, 2.6.0, 2.7.0.
]]>
BobRay Feb 04, 2019, 08:42 AM https://forums.modx.com/thread/104735/modx-broken#dis-post-563927
<![CDATA[Re: MODx broken?]]> https://forums.modx.com/thread/104735/modx-broken#dis-post-563913 Quote from: BobRay at Feb 01, 2019, 11:49 PM
You're running MODX Revolution 2.0.3, which is quite old. It's possible that your host has updated PHP to PHP 7, which would probably cause trouble with that version. You could try switching back to an earlier version in cPanel (make sure it's at least PHP 5.4).

You could also follow the upgrade instructions here to upgrade: https://bobsguides.com/modx-upgrade-faq.html.

Do the upgrades in steps: 2.3.0, 2.4.0, 2.5.0, 2.6.0, 2.7.0.
i have made an help-ticket by my hosting, and they say this:




Dear,

Thanks for your message.
We have checked this with various PHP versions and with debug mode On, but this does not clarify the problem and the website does not work: https://www.versio.nl/artikelen/345-hoe-selecteer-ik-een- other-php version
We do not have a department within Versio that can solve script problems, I advise you to have this checked by a Modx programmer. I read that you are also using an older version, you may be able to upgrade to the latest version while retaining the current theme and current database to avoid losing data.
If you have further questions, we will gladly help you further.

Sincerely,
F - Versio Employee

]]>
neo-81 Feb 03, 2019, 10:25 AM https://forums.modx.com/thread/104735/modx-broken#dis-post-563913
<![CDATA[Re: MODx broken?]]> https://forums.modx.com/thread/104735/modx-broken#dis-post-563896
You could also follow the upgrade instructions here to upgrade: https://bobsguides.com/modx-upgrade-faq.html.

Do the upgrades in steps: 2.3.0, 2.4.0, 2.5.0, 2.6.0, 2.7.0.]]>
BobRay Feb 01, 2019, 11:49 PM https://forums.modx.com/thread/104735/modx-broken#dis-post-563896
<![CDATA[Re: MODx broken?]]> https://forums.modx.com/thread/104735/modx-broken#dis-post-563889 Quote from: BobRay at Feb 01, 2019, 04:12 AM
OK, your MODX install is in the public_html folder. In that folder, go into the core directory, then into the core/cache directory under it. Delete all the files in that cache folder (but not the cache folder itself). Be sure you're deleting the files in the cache directory.

Then, go back up to the core folder. In that folder, you'll see a folder called docs. Inside that docs folder, find the file called version.inc.php. Open it in the file viewer and find the section at the top that looks something like this:

$v['version']= '2'; // Current version.
$v['major_version']= '5'; // Current major version.
$v['minor_version']= '1'; // Current minor version.
$v['patch_level']= 'pl'; // Current patch level.
$v['code_name']= 'Revolution'; // Current codename.


Paste that code here so we can tell which version of MODX Revolution you are running.

Once you've done all that, try your Manager login again. Clearing the cache might fix things.



the cache folder, I clear almost every montg / every 2 months, cause otherwhise the whole site is blanc


]]>
neo-81 Feb 01, 2019, 09:07 AM https://forums.modx.com/thread/104735/modx-broken#dis-post-563889
<![CDATA[Re: MODx broken?]]> https://forums.modx.com/thread/104735/modx-broken#dis-post-563881
Then, go back up to the core folder. In that folder, you'll see a folder called docs. Inside that docs folder, find the file called version.inc.php. Open it in the file viewer and find the section at the top that looks something like this:

$v['version']= '2'; // Current version.
$v['major_version']= '5'; // Current major version.
$v['minor_version']= '1'; // Current minor version.
$v['patch_level']= 'pl'; // Current patch level.
$v['code_name']= 'Revolution'; // Current codename.


Paste that code here so we can tell which version of MODX Revolution you are running.

Once you've done all that, try your Manager login again. Clearing the cache might fix things.]]>
BobRay Feb 01, 2019, 04:12 AM https://forums.modx.com/thread/104735/modx-broken#dis-post-563881
<![CDATA[Re: MODx broken?]]> https://forums.modx.com/thread/104735/modx-broken#dis-post-563879 Quote from: BobRay at Jan 31, 2019, 09:32 PM
Look in public_html for a directory that contains a 'manager' directory. That's the root of your MODX site. Also, look for a directory called core/cache. Try deleting all files in the core/cache directory (but not the directory itself).

There is a map, called "manager"


Inside that map, there is:


Inside the map "core" i have sometimes, to rename te folder "Cache" to "Cache-Old" or "Cache-old1, 2, 3, 4 etc etc etc" cause the whole site was blanc
]]>
neo-81 Jan 31, 2019, 10:05 PM https://forums.modx.com/thread/104735/modx-broken#dis-post-563879